summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ada/aunit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ada/aunit')
-rw-r--r--dev-ada/aunit/Manifest3
-rw-r--r--dev-ada/aunit/aunit-1.05.ebuild50
-rw-r--r--dev-ada/aunit/aunit-2.01.ebuild51
-rw-r--r--dev-ada/aunit/aunit-2.03.ebuild51
-rw-r--r--dev-ada/aunit/metadata.xml6
5 files changed, 161 insertions, 0 deletions
diff --git a/dev-ada/aunit/Manifest b/dev-ada/aunit/Manifest
new file mode 100644
index 000000000000..6cfe5d69f1e6
--- /dev/null
+++ b/dev-ada/aunit/Manifest
@@ -0,0 +1,3 @@
+DIST aunit-1.05.tar.bz2 109000 SHA256 76a7240203ab708743bc40fe29209e04b3edbe429a4dfb35be580fc80d490b09 SHA512 3a51f3d614061bed124636852b3677f95a739b0ffc748d2f6570cd2bfcf73db36364504b07e4169e268861bdce5a22e2d3a467d809a8776a8e407e83a7364a77 WHIRLPOOL eb403e4e30887ae202302d8b26ba3909190bd05d721688cde685b98539eb37c4db52f9a07e9547be380d735593dfd349a2e4d1f55153d5b2cdb38d3caa0403fe
+DIST aunit-2.01.tar.bz2 186622 SHA256 fca41d07a7e5a7f82e8f53fb8d579c250ae5436adf9f677dfa2d3f657453b8f9 SHA512 6a07745cc6d4027b48064240d9511634725201ed3f59f3adb6907ec3b58409cca472cd0790c364ceb412c14fec7633d62277cdaf94c66458fab5c11c8fe058bf WHIRLPOOL fea15eeece2023f6388e7ad9dafcdd93c1d263b8a356549d85189ab137868b7e7d7641cf72440dfb39c4ebba37bd19dd665e6d434b506b84882955aa04bd46a7
+DIST aunit-2.03.tar.bz2 218201 SHA256 b57862b01094e9db2d564aeb25377cf91a678802f4124e455a432e1ec8fb8367 SHA512 f3afb4ae05e493eb598368f223dc8dc1740ee11b58f00394b6bececba4a2c7409ed2b48bbc7104a4099ac919e51e741ebe2738133410274240ccecd23fb2ad7d WHIRLPOOL 4e3b46b8156fc25fb2f1270cb08273b81ed5e054c196453745a77a1e99302857b7ecd36a6c071981e7e09f1efc7cb5d1dac933053f60dd5828bb0aa62fc7570a
diff --git a/dev-ada/aunit/aunit-1.05.ebuild b/dev-ada/aunit/aunit-1.05.ebuild
new file mode 100644
index 000000000000..cf7eacee4d89
--- /dev/null
+++ b/dev-ada/aunit/aunit-1.05.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnat
+
+IUSE=""
+
+DESCRIPTION="Aunit, Ada unit testing framework"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="https://libre.adacore.com/aunit/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+
+DEPEND="virtual/ada"
+RDEPEND="${DEPEND}"
+
+lib_compile() {
+ gnatmake -Paunit
+ gnatmake -Paunit_dyn
+}
+
+lib_install() {
+ mv aunit/lib/* ${DL}
+ chmod 0444 ${DL}/*.ali
+}
+
+src_install () {
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins aunit/*/*.ad?
+
+ dodir ${AdalibDataDir}/${PN}
+ insinto ${AdalibDataDir}/${PN}
+ doins -r support/aunit.xml template/
+
+ #set up environment
+ echo "LDPATH=%DL%" > ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=/usr/include/ada/${PN}" >> ${LibEnv}
+
+ gnat_src_install
+
+ dodoc README docs/aunit.txt
+ dohtml docs/aunit.{html,css}
+ doinfo docs/aunit.info
+ cp -dPr test/ docs/aunit.pdf "${D}/usr/share/doc/${PF}"
+}
diff --git a/dev-ada/aunit/aunit-2.01.ebuild b/dev-ada/aunit/aunit-2.01.ebuild
new file mode 100644
index 000000000000..14a7c20a5e27
--- /dev/null
+++ b/dev-ada/aunit/aunit-2.01.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnat
+
+IUSE=""
+
+DESCRIPTION="Aunit, Ada unit testing framework"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="https://libre.adacore.com/aunit/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+
+DEPEND="virtual/ada"
+RDEPEND="${DEPEND}"
+
+lib_compile() {
+ cd aunit
+ SUPPORT_EXCEPTION=yes SUPPORT_CALENDAR=yes gnatmake -Paunit_build
+ SUPPORT_EXCEPTION=yes SUPPORT_CALENDAR=yes gnatmake -Paunit_build_dyn
+}
+
+lib_install() {
+ mv aunit/lib/* ${DL}
+ chmod 0444 ${DL}/*.ali
+}
+
+src_install () {
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins aunit/*/*.ad? aunit/framework/*/*.ad?
+
+ dodir ${AdalibDataDir}/${PN}
+ insinto ${AdalibDataDir}/${PN}
+ doins -r support/aunit.xml template/
+
+ #set up environment
+ echo "LDPATH=%DL%" > ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=/usr/include/ada/${PN}" >> ${LibEnv}
+
+ gnat_src_install
+
+ dodoc README docs/aunit.txt
+ dohtml docs/aunit.{html,css}
+ doinfo docs/aunit.info
+ cp -dPr test/ docs/aunit.pdf "${D}/usr/share/doc/${PF}"
+}
diff --git a/dev-ada/aunit/aunit-2.03.ebuild b/dev-ada/aunit/aunit-2.03.ebuild
new file mode 100644
index 000000000000..4fb13fd1787c
--- /dev/null
+++ b/dev-ada/aunit/aunit-2.03.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit gnat
+
+IUSE=""
+
+DESCRIPTION="Aunit, Ada unit testing framework"
+SRC_URI="http://dev.gentoo.org/~george/src/${P}.tar.bz2"
+HOMEPAGE="https://libre.adacore.com/aunit/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+
+DEPEND="virtual/ada"
+RDEPEND="${DEPEND}"
+
+lib_compile() {
+ cd aunit
+ SUPPORT_EXCEPTION=yes SUPPORT_CALENDAR=yes gnatmake -Paunit_build
+ SUPPORT_EXCEPTION=yes SUPPORT_CALENDAR=yes gnatmake -Paunit_build_dyn
+}
+
+lib_install() {
+ mv aunit/lib/* ${DL}
+ chmod 0444 ${DL}/*.ali
+}
+
+src_install () {
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins aunit/*/*.ad? aunit/framework/*/*.ad?
+
+ dodir ${AdalibDataDir}/${PN}
+ insinto ${AdalibDataDir}/${PN}
+ doins -r support/aunit.xml template/
+
+ #set up environment
+ echo "LDPATH=%DL%" > ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=/usr/include/ada/${PN}" >> ${LibEnv}
+
+ gnat_src_install
+
+ dodoc README docs/aunit.txt
+ dohtml docs/aunit.{html,css}
+ doinfo docs/aunit.info
+ cp -dPr test/ docs/aunit.pdf "${D}/usr/share/doc/${PF}"
+}
diff --git a/dev-ada/aunit/metadata.xml b/dev-ada/aunit/metadata.xml
new file mode 100644
index 000000000000..83f771493132
--- /dev/null
+++ b/dev-ada/aunit/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ada</herd>
+<longdescription>AUnit is a set of Ada packages based on the xUnit family of unit test frameworks. It's intended as a developer's tool to facilitate confident writing and evolution of Ada software. It is purposely lightweight, as one of its main goals is to make it easy to develop and run unit tests, rather than to generate artifacts for process management. The framework supports easy composition of sets of unit tests to provide flexibility in determining what tests to run for a given purpose.</longdescription>
+</pkgmetadata>