summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2018-11-10 15:24:28 +0100
committerTupone Alfredo <tupone@gentoo.org>2018-11-10 15:26:52 +0100
commitcd000e82e748a1d64c1d0e7c18c357179e7eb668 (patch)
treeb2ce9e327490c90abf605ee7ac407f1385f2a0e8 /dev-ada/aws
parentdev-python/pipenv: Add python3.7 support (diff)
downloadgentoo-cd000e82e748a1d64c1d0e7c18c357179e7eb668.tar.gz
gentoo-cd000e82e748a1d64c1d0e7c18c357179e7eb668.tar.bz2
gentoo-cd000e82e748a1d64c1d0e7c18c357179e7eb668.zip
dev-ada/aws: remove GCC hack
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ada/aws')
-rw-r--r--dev-ada/aws/aws-2017.ebuild12
-rw-r--r--dev-ada/aws/aws-2018.ebuild14
-rw-r--r--dev-ada/aws/files/aws-2016-gentoo.patch16
3 files changed, 12 insertions, 30 deletions
diff --git a/dev-ada/aws/aws-2017.ebuild b/dev-ada/aws/aws-2017.ebuild
index 77fbba8c7964..081d598a0027 100644
--- a/dev-ada/aws/aws-2017.ebuild
+++ b/dev-ada/aws/aws-2017.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -29,16 +29,12 @@ S="${WORKDIR}"/${MY_P}
PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
src_configure() {
- emake -j1 setup prefix=/usr
+ emake -j1 setup prefix=/usr \
+ GPRBUILD="/usr/bin/gprbuild -v"
}
src_compile() {
- if use gnat_2016; then
- GCC_PV=4.9.4
- else
- GCC_PV=6.3.0
- fi
- emake GCC=${CHOST}-gcc-${GCC_PV} \
+ emake \
PROCESSORS=$(makeopts_jobs) \
DEBUG=true \
GPRBUILD="/usr/bin/gprbuild -v"
diff --git a/dev-ada/aws/aws-2018.ebuild b/dev-ada/aws/aws-2018.ebuild
index 4222e66bbdd8..f18391af4105 100644
--- a/dev-ada/aws/aws-2018.ebuild
+++ b/dev-ada/aws/aws-2018.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,18 +28,12 @@ S="${WORKDIR}"/${MY_P}
PATCHES=( "${FILESDIR}"/${PN}-2016-gentoo.patch )
src_configure() {
- emake -j1 setup prefix=/usr ENABLE_SHARED=true
+ emake -j1 setup prefix=/usr ENABLE_SHARED=true \
+ GPRBUILD="/usr/bin/gprbuild -v"
}
src_compile() {
- if use gnat_2018; then
- GCC_PV=7.3.1
- elif use gnat_2017; then
- GCC_PV=6.3.0
- else
- GCC_PV=4.9.4
- fi
- emake GCC=${CHOST}-gcc-${GCC_PV} \
+ emake \
PROCESSORS=$(makeopts_jobs) \
GPRBUILD="/usr/bin/gprbuild -v"
}
diff --git a/dev-ada/aws/files/aws-2016-gentoo.patch b/dev-ada/aws/files/aws-2016-gentoo.patch
index b33073afa443..8894e014e333 100644
--- a/dev-ada/aws/files/aws-2016-gentoo.patch
+++ b/dev-ada/aws/files/aws-2016-gentoo.patch
@@ -1,13 +1,5 @@
---- aws-gpl-2016-src/shared.gpr.old 2017-01-30 20:00:39.022743691 +0100
-+++ aws-gpl-2016-src/shared.gpr 2017-01-30 20:01:20.524985069 +0100
-@@ -130,6 +130,7 @@
- package Compiler is
-
- for Driver ("Makefile") use "";
-+ for Driver ("C") use External ("GCC", "gcc");
-
- case Build is
- when "Debug" =>
+--- a/shared.gpr 2017-01-30 20:00:39.022743691 +0100
++++ b/shared.gpr 2017-01-30 20:01:20.524985069 +0100
@@ -151,11 +151,11 @@
end case;
@@ -23,8 +15,8 @@
-- Disable validity check on this unit to work-around N728-028
-- ADAFLAGS and CFLAGS should come last so that command line
---- aws-gpl-2016-src/include/include.gpr.old 2017-02-17 22:09:14.361695926 +0100
-+++ aws-gpl-2016-src/include/include.gpr 2017-02-17 22:11:36.497215517 +0100
+--- a/include/include.gpr 2017-02-17 22:09:14.361695926 +0100
++++ b/include/include.gpr 2017-02-17 22:11:36.497215517 +0100
@@ -54,7 +54,7 @@
when "Release" =>