summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-30 16:20:53 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-30 18:57:35 -0700
commit1d8f8196c5505357f254a5b2bedd3fea74860a14 (patch)
tree838414839b48205c718b982e90642c9d1f1dc9c0 /dev-cpp/glibmm/glibmm-2.68.0.ebuild
parentdev-cpp/cairomm: Drop old versions (diff)
downloadgentoo-1d8f8196c5505357f254a5b2bedd3fea74860a14.tar.gz
gentoo-1d8f8196c5505357f254a5b2bedd3fea74860a14.tar.bz2
gentoo-1d8f8196c5505357f254a5b2bedd3fea74860a14.zip
dev-cpp/glibmm: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/glibmm/glibmm-2.68.0.ebuild')
-rw-r--r--dev-cpp/glibmm/glibmm-2.68.0.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-cpp/glibmm/glibmm-2.68.0.ebuild b/dev-cpp/glibmm/glibmm-2.68.0.ebuild
deleted file mode 100644
index 2cf6d1781f54..000000000000
--- a/dev-cpp/glibmm/glibmm-2.68.0.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-inherit gnome.org meson multilib-minimal python-any-r1
-
-DESCRIPTION="C++ interface for glib2"
-HOMEPAGE="https://www.gtkmm.org"
-
-LICENSE="LGPL-2.1+"
-SLOT="2.68"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
-IUSE="doc debug test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.63.0:2[${MULTILIB_USEDEP}]
- dev-libs/libsigc++:3[doc?,${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
- doc? (
- app-doc/doxygen[dot]
- dev-lang/perl
- dev-libs/libxslt
- )
-"
-
-src_prepare() {
- default
-
- # giomm_tls_client requires FEATURES=-network-sandbox and glib-networking rdep
- sed -i -e '/giomm_tls_client/d' tests/meson.build || die
-
- if ! use test; then
- sed -i -e "/^subdir('tests')/d" meson.build || die
- fi
-}
-
-multilib_src_configure() {
- local emesonargs=(
- -Dwarnings=min
- -Dbuild-deprecated-api=true
- -Dbuild-documentation=$(usex doc true false)
- -Ddebug-refcounting=$(usex debug true false)
- -Dbuild-examples=false
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- meson_src_test
-}
-
-multilib_src_install() {
- meson_src_install
-}