summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-03-02 13:15:13 -0500
committerMike Frysinger <vapier@gentoo.org>2016-03-02 13:15:13 -0500
commit86374a0eddd3d30fc8591c2bbe543af9584676de (patch)
treecf20b267612b93795a43f56f1b929d9390e0d27f /dev-cpp/glog
parentmedia-tv/kodi: drop libdvdcss requirement to match upstream (diff)
downloadgentoo-86374a0eddd3d30fc8591c2bbe543af9584676de.tar.gz
gentoo-86374a0eddd3d30fc8591c2bbe543af9584676de.tar.bz2
gentoo-86374a0eddd3d30fc8591c2bbe543af9584676de.zip
dev-cpp/glog: version bump to 0.3.4
Diffstat (limited to 'dev-cpp/glog')
-rw-r--r--dev-cpp/glog/Manifest1
-rw-r--r--dev-cpp/glog/glog-0.3.4.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-cpp/glog/Manifest b/dev-cpp/glog/Manifest
index 275c924bceb4..ac070693f718 100644
--- a/dev-cpp/glog/Manifest
+++ b/dev-cpp/glog/Manifest
@@ -1,3 +1,4 @@
DIST glog-0.3.1-1.tar.gz 491798 SHA256 0a5ce945aaa5c64cb3889bf4844a0459263c06a77ad549042230dfea316787cb SHA512 9bf48fe53e45a7af24ea6cfe27f6a4b592efe9911e2c9764c364d551ad9a7ab4eae2ace64873ec9bd2202323032ffbdbbda5ea9e7514aa0e324e30048c238e96 WHIRLPOOL 21593af929da3db01527c6e9111b75a7318be2c14abebbfb1e09f0a6ac12442e522cb510a776ef95136168baa1400e759bb69f7670192301ed1044db00eac385
DIST glog-0.3.2.tar.gz 478666 SHA256 5e47f9437e97cb1621930dea3c557a2801ddac3b5db1a9fd0c3cde399f2c9ccd SHA512 75f61d63fd65df40995b657c47a6c2dcabd2e25716c7ac1d4229dfc6a43e5957576b9d090997ae0ec81b30b60df6fdc6ae1294a087cbc3d03ad42295980fddfd WHIRLPOOL c6649da59d7de673b39fdb4f6930c44ab6887595733468e9ed81928525892f21c23e0f8e9cb7aac383fdb3afa6f86aa683ccff5502b445c546f00bc44f4c75f2
DIST glog-0.3.3.tar.gz 509676 SHA256 fbf90c2285ba0561db7a40f8a4eefb9aa963e7d399bd450363e959929fe849d0 SHA512 95418ff0857415a0fbc15caeb22a13f3b6736618adcc3c30e054626f1397bc58399c45f68784c70b1f5dc594ebc6ea66e386896beab5c20be72dd53b25f5a4ac WHIRLPOOL 7ba26a936e3ac18afbccf141b888a885f3f9847d4f19c0ebad416d16fcff936b9622e03aec155f77622759a40e8684673c29648c026426326239f4485113c6cf
+DIST glog-0.3.4.tar.gz 522508 SHA256 ce99d58dce74458f7656a68935d7a0c048fa7b4626566a71b7f4e545920ceb10 SHA512 139525b546a9eccacc9bebf7cc3053ba52229e9488485ad45344c3d3134ca819d3b571250c0e3a6d84097009c8be89b0f4fa16ef5ec838ffcc237ae11c3a034c WHIRLPOOL b6787336ea55de2f6574e29bc4649a7c64aa5d5e8a07ab15c2c5754ebf9cfefd1405c64cc4dfecab557814991ae4c97be078d21916181850ee12b853918c0a27
diff --git a/dev-cpp/glog/glog-0.3.4.ebuild b/dev-cpp/glog/glog-0.3.4.ebuild
new file mode 100644
index 000000000000..070545933668
--- /dev/null
+++ b/dev-cpp/glog/glog-0.3.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="Google's C++ logging library"
+HOMEPAGE="https://github.com/google/glog"
+SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="gflags static-libs unwind test"
+
+RDEPEND="gflags? ( >=dev-cpp/gflags-2.0-r1[${MULTILIB_USEDEP}] )
+ unwind? ( sys-libs/libunwind )"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-cpp/gmock-1.7.0-r1[${MULTILIB_USEDEP}]
+ >=dev-cpp/gtest-1.6.0-r2[${MULTILIB_USEDEP}]
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.2-avoid-inline-asm.patch
+ # Fix the --dodcdir flag:
+ # https://code.google.com/p/google-glog/issues/detail?id=193
+ sed -i \
+ -e '/^docdir =/s:=.*:= @docdir@:' \
+ Makefile.in || die
+}
+
+multilib_src_configure() {
+ use test || export ac_cv_prog_GTEST_CONFIG=no
+ ECONF_SOURCE=${S} \
+ ac_cv_lib_gflags_main=$(usex gflags) \
+ ac_cv_lib_unwind_backtrace=$(usex unwind) \
+ econf \
+ --docdir="\$(datarootdir)/doc/${PF}" \
+ --htmldir='$(docdir)/html' \
+ $(use_enable static-libs static)
+}
+
+_emake() {
+ # The tests always get built ... disable them when unused.
+ emake $(usex test '' noinst_PROGRAMS=) "$@"
+}
+
+multilib_src_compile() {
+ _emake
+}
+
+multilib_src_install() {
+ _emake install DESTDIR="${D}"
+}
+
+multilib_src_install_all() {
+ # Punt docs we don't care about (NEWS is 0 bytes).
+ rm "${ED}"/usr/share/doc/${PF}/{COPYING,NEWS,README.windows} || die
+
+ # --htmldir doesn't work (yet):
+ # https://code.google.com/p/google-glog/issues/detail?id=144
+ dohtml "${ED}"/usr/share/doc/${PF}/*
+ rm "${ED}"/usr/share/doc/${PF}/*.{html,css}
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}