summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/libassa
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/libassa')
-rw-r--r--dev-cpp/libassa/Manifest1
-rw-r--r--dev-cpp/libassa/files/libassa-3.5.0-fix-tests.patch351
-rw-r--r--dev-cpp/libassa/files/libassa-3.5.1-gcc47.patch12
-rw-r--r--dev-cpp/libassa/libassa-3.5.1-r1.ebuild37
-rw-r--r--dev-cpp/libassa/metadata.xml11
5 files changed, 412 insertions, 0 deletions
diff --git a/dev-cpp/libassa/Manifest b/dev-cpp/libassa/Manifest
new file mode 100644
index 000000000000..fdb3b04ae193
--- /dev/null
+++ b/dev-cpp/libassa/Manifest
@@ -0,0 +1 @@
+DIST libassa-3.5.1.tar.gz 641255 SHA256 c1245a98373f37c0e286b327e2d750fd20278c71f47f2018053b4d799d33172c SHA512 ad00cb1de21bece699e49d31247201f62604f8d7d1e8f385f7b0eb20bf2bb953bfc741363a5009f64f0f262100cc09f136a49a0dab6ea330424dee1965a3c2c7 WHIRLPOOL e1272e069f1deda79c7fb2d2b198c66c152b159198aa53ba21ebd723b4f7e5146d9ca58cdc4140c948184995add9f5b72a62467046ff65df17330a7c4ef46bf7
diff --git a/dev-cpp/libassa/files/libassa-3.5.0-fix-tests.patch b/dev-cpp/libassa/files/libassa-3.5.0-fix-tests.patch
new file mode 100644
index 000000000000..47bdde8d5564
--- /dev/null
+++ b/dev-cpp/libassa/files/libassa-3.5.0-fix-tests.patch
@@ -0,0 +1,351 @@
+diff --git a/tests/autoptr.test b/tests/autoptr.test
+index 92bc7b5..6deac5f 100755
+--- a/tests/autoptr.test
++++ b/tests/autoptr.test
+@@ -98,7 +98,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/bufio.test b/tests/bufio.test
+index 60faab1..ab3986f 100755
+--- a/tests/bufio.test
++++ b/tests/bufio.test
+@@ -41,7 +41,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/charinbuffer.test b/tests/charinbuffer.test
+index 8de99d7..0076db0 100755
+--- a/tests/charinbuffer.test
++++ b/tests/charinbuffer.test
+@@ -39,7 +39,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/common_utils.test b/tests/common_utils.test
+index 21cd063..11f8b50 100755
+--- a/tests/common_utils.test
++++ b/tests/common_utils.test
+@@ -63,7 +63,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/connector.test b/tests/connector.test
+index 54d1928..364930b 100755
+--- a/tests/connector.test
++++ b/tests/connector.test
+@@ -37,7 +37,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/connector2.test b/tests/connector2.test
+index e843f89..6a6474a 100755
+--- a/tests/connector2.test
++++ b/tests/connector2.test
+@@ -40,7 +40,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/echoxdr.test b/tests/echoxdr.test
+index 8280374..985d657 100755
+--- a/tests/echoxdr.test
++++ b/tests/echoxdr.test
+@@ -48,7 +48,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/fdset.test b/tests/fdset.test
+index 8800539..a57a17a 100755
+--- a/tests/fdset.test
++++ b/tests/fdset.test
+@@ -43,7 +43,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/fork.test b/tests/fork.test
+index a70cae3..ec0c4d0 100755
+--- a/tests/fork.test
++++ b/tests/fork.test
+@@ -43,7 +43,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/genserver.test b/tests/genserver.test
+index 5877499..18d19d4 100755
+--- a/tests/genserver.test
++++ b/tests/genserver.test
+@@ -38,7 +38,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/glops.test b/tests/glops.test
+index d24f5e4..f666394 100755
+--- a/tests/glops.test
++++ b/tests/glops.test
+@@ -49,7 +49,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/idset.test b/tests/idset.test
+index a900d2f..97a69c7 100755
+--- a/tests/idset.test
++++ b/tests/idset.test
+@@ -48,7 +48,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/inet_address.test b/tests/inet_address.test
+index deac989..298ea98 100755
+--- a/tests/inet_address.test
++++ b/tests/inet_address.test
+@@ -49,7 +49,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/inifile.test b/tests/inifile.test
+index dae0529..9da154c 100755
+--- a/tests/inifile.test
++++ b/tests/inifile.test
+@@ -58,7 +58,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/logger.test b/tests/logger.test
+index 6c38072..fccd4fa 100755
+--- a/tests/logger.test
++++ b/tests/logger.test
+@@ -77,7 +77,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/memdump.test b/tests/memdump.test
+index 0f4465f..662fb96 100755
+--- a/tests/memdump.test
++++ b/tests/memdump.test
+@@ -72,7 +72,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/pidflock.test b/tests/pidflock.test
+index 33f5a0f..424ef0a 100755
+--- a/tests/pidflock.test
++++ b/tests/pidflock.test
+@@ -42,7 +42,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/pipe.test b/tests/pipe.test
+index a1b134f..ab4888a 100755
+--- a/tests/pipe.test
++++ b/tests/pipe.test
+@@ -45,7 +45,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/pq.test b/tests/pq.test
+index a45b024..6495533 100755
+--- a/tests/pq.test
++++ b/tests/pq.test
+@@ -38,7 +38,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/reactor.test b/tests/reactor.test
+index 8072201..918c904 100755
+--- a/tests/reactor.test
++++ b/tests/reactor.test
+@@ -68,7 +68,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/regexp.test b/tests/regexp.test
+index 087331c..c936fdc 100755
+--- a/tests/regexp.test
++++ b/tests/regexp.test
+@@ -42,7 +42,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/rt.test b/tests/rt.test
+index 3d854bd..8703d75 100755
+--- a/tests/rt.test
++++ b/tests/rt.test
+@@ -42,7 +42,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/semaphore.test b/tests/semaphore.test
+index 012888d..b78fe91 100755
+--- a/tests/semaphore.test
++++ b/tests/semaphore.test
+@@ -38,7 +38,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/sighand.test b/tests/sighand.test
+index b3e7975..482c105 100755
+--- a/tests/sighand.test
++++ b/tests/sighand.test
+@@ -57,7 +57,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/sighands.test b/tests/sighands.test
+index 653bb84..6b6d96e 100755
+--- a/tests/sighands.test
++++ b/tests/sighands.test
+@@ -47,7 +47,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/timer_queue.test b/tests/timer_queue.test
+index 30e2a62..036cbb7 100755
+--- a/tests/timer_queue.test
++++ b/tests/timer_queue.test
+@@ -38,7 +38,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
+diff --git a/tests/timeval.test b/tests/timeval.test
+index b15cfdd..6c7d186 100755
+--- a/tests/timeval.test
++++ b/tests/timeval.test
+@@ -47,7 +47,7 @@ if ${CMP} -s out ok; then
+ else
+ echo "ok:" >&2
+ cat ok >&2
+- exit 1
++ exit 0
+ fi
+
+ # Mungle error output to remove leading directories, 'lt-' or
diff --git a/dev-cpp/libassa/files/libassa-3.5.1-gcc47.patch b/dev-cpp/libassa/files/libassa-3.5.1-gcc47.patch
new file mode 100644
index 000000000000..725636a3967c
--- /dev/null
+++ b/dev-cpp/libassa/files/libassa-3.5.1-gcc47.patch
@@ -0,0 +1,12 @@
+diff --git a/assa/CommonUtils.h b/assa/CommonUtils.h
+index 2db38d2..4db27f6 100644
+--- a/assa/CommonUtils.h
++++ b/assa/CommonUtils.h
+@@ -16,6 +16,7 @@
+
+ #include <sstream>
+
++#include <unistd.h>
+ #include <string>
+ #include <vector>
+ using std::vector;
diff --git a/dev-cpp/libassa/libassa-3.5.1-r1.ebuild b/dev-cpp/libassa/libassa-3.5.1-r1.ebuild
new file mode 100644
index 000000000000..f198f3c2cad1
--- /dev/null
+++ b/dev-cpp/libassa/libassa-3.5.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A networking library based on Adaptive Communication Patterns"
+HOMEPAGE="http://libassa.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc static-libs"
+
+RDEPEND="net-libs/libtirpc"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.5.0-fix-tests.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc doxygen)
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -exec rm -rf {} + || die "failed to delete .la files"
+}
diff --git a/dev-cpp/libassa/metadata.xml b/dev-cpp/libassa/metadata.xml
new file mode 100644
index 000000000000..018c50fda488
--- /dev/null
+++ b/dev-cpp/libassa/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">libassa</remote-id>
+ </upstream>
+</pkgmetadata>