summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 19:56:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 21:07:25 +0100
commitd76b148ac130c329531b4758a3b35648d89a263d (patch)
tree3b0aa3743bc9811bdbb91374bfafe506d95f89c1 /dev-cpp/libcmis/libcmis-9999.ebuild
parentmedia-libs/gd-2.2.5-r1: hppa stable, bug 664732 (diff)
downloadgentoo-d76b148ac130c329531b4758a3b35648d89a263d.tar.gz
gentoo-d76b148ac130c329531b4758a3b35648d89a263d.tar.bz2
gentoo-d76b148ac130c329531b4758a3b35648d89a263d.zip
dev-cpp/libcmis: 0.5.2 version bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp/libcmis/libcmis-9999.ebuild')
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 8513c4a8cb4f..33f9f92173ea 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,7 @@ SLOT="0.5"
# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="man static-libs test"
@@ -50,20 +50,22 @@ RESTRICT="test"
src_prepare() {
default
- [[ ${PV} = *_pre* || ${PV} = 9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
# bug 618778
append-cxxflags -std=c++14
- econf \
- --program-suffix=-$(ver_cut 1-2) \
- --disable-werror \
- $(use_with man) \
- $(use_enable static-libs static) \
- $(use_enable test tests) \
+ local myeconfargs=(
+ --program-suffix=-$(ver_cut 1-2)
+ --disable-werror
+ $(use_with man)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
--enable-client
+ )
+ econf "${myeconfargs[@]}"
}
src_install() {