summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-31 07:58:57 +0000
committerSam James <sam@gentoo.org>2021-10-31 07:58:57 +0000
commit39d9aa42d1d4da8a512c63fcb24e90c9db71d178 (patch)
tree37bf9930139c2da96b9937129a4a4d6a07c3c0a8 /dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild
parentnet-im/zoom: Remove old (diff)
downloadgentoo-39d9aa42d1d4da8a512c63fcb24e90c9db71d178.tar.gz
gentoo-39d9aa42d1d4da8a512c63fcb24e90c9db71d178.tar.bz2
gentoo-39d9aa42d1d4da8a512c63fcb24e90c9db71d178.zip
dev-cpp/lucene++: depend on boost[zlib]
Closes: https://bugs.gentoo.org/800530 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild')
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild b/dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild
new file mode 100644
index 000000000000..4084b8771570
--- /dev/null
+++ b/dev-cpp/lucene++/lucene++-3.0.7-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake
+
+DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:=[zlib]"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.58.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEMO=OFF
+ -DENABLE_TEST=OFF
+ )
+
+ cmake_src_configure
+}