summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-01 11:35:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-01 11:35:16 +0200
commit006a5c467708ab7d8e7469f4d57a070d32ca2657 (patch)
treeab33d5896a72e39a710a7c3218c1a272723c6c40 /dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild
parentdev-python/jarowinkler: Remove old (diff)
downloadgentoo-006a5c467708ab7d8e7469f4d57a070d32ca2657.tar.gz
gentoo-006a5c467708ab7d8e7469f4d57a070d32ca2657.tar.bz2
gentoo-006a5c467708ab7d8e7469f4d57a070d32ca2657.zip
dev-cpp/rapidfuzz-cpp: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild')
-rw-r--r--dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild b/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild
deleted file mode 100644
index 99e66055cc0f..000000000000
--- a/dev-cpp/rapidfuzz-cpp/rapidfuzz-cpp-1.6.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Rapid fuzzy string matching in C++"
-HOMEPAGE="https://github.com/maxbachmann/rapidfuzz-cpp/"
-SRC_URI="
- https://github.com/maxbachmann/rapidfuzz-cpp/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- >=dev-cpp/catch-3
- )
-"
-
-src_prepare() {
- # apparently "C++ best practices" don't mind fetching random stuff
- # at build time
- sed -i -e '/aminya/,/^)/d' test/CMakeLists.txt || die
- find -name 'CMakeLists.txt' -exec \
- sed -i -e 's:project_warnings::' {} + || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DRAPIDFUZZ_BUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}