summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-05 10:42:14 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-05 11:19:02 +0200
commit208a3d824ffa49a276a684bb812446d86902e185 (patch)
tree382bbfda395726d87b0b3c86645743e06fe95dc4 /dev-cpp/threadpool
parentmedia-video/ffmpeg: remove old (diff)
downloadgentoo-208a3d824ffa49a276a684bb812446d86902e185.tar.gz
gentoo-208a3d824ffa49a276a684bb812446d86902e185.tar.bz2
gentoo-208a3d824ffa49a276a684bb812446d86902e185.zip
dev-cpp/threadpool: Modernize to EAPI=6
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-cpp/threadpool')
-rw-r--r--dev-cpp/threadpool/files/threadpool-0.2.5-memleak.patch4
-rw-r--r--dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild40
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-cpp/threadpool/files/threadpool-0.2.5-memleak.patch b/dev-cpp/threadpool/files/threadpool-0.2.5-memleak.patch
index 886ce5836012..26d89d1d5c25 100644
--- a/dev-cpp/threadpool/files/threadpool-0.2.5-memleak.patch
+++ b/dev-cpp/threadpool/files/threadpool-0.2.5-memleak.patch
@@ -10,8 +10,8 @@ memory.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
---- threadpool-0_2_5-src/threadpool/boost/threadpool/detail/pool_core.hpp 2012-09-27 22:33:21.098626892 -0700
-+++ threadpool-0_2_5-src/threadpool/boost/threadpool/detail/pool_core.hpp 2012-09-27 22:51:12.291997839 -0700
+--- threadpool/boost/threadpool/detail/pool_core.hpp
++++ threadpool/boost/threadpool/detail/pool_core.hpp
@@ -150,6 +150,7 @@
/// Destructor.
~pool_core()
diff --git a/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild b/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..3b125a50fd41
--- /dev/null
+++ b/dev-cpp/threadpool/threadpool-0.2.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A cross-platform C++ thread pool library (built on top of Boost)"
+HOMEPAGE="http://threadpool.sourceforge.net/"
+MY_PV=${PV//./_}
+MY_P=${PN}-${MY_PV}
+SRC_URI_BASE="mirror://sourceforge/threadpool/threadpool/${PV}%20%28Stable%29"
+SRC_URI="${SRC_URI_BASE}/${MY_P}-src.zip
+ doc? ( ${SRC_URI_BASE}/${MY_P}-doc.zip )"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND="dev-libs/boost"
+
+S="${WORKDIR}/${MY_P}-src/${PN}"
+
+DOCS=( README TODO CHANGE_LOG )
+PATCHES=( "${FILESDIR}/${P}-memleak.patch" )
+
+src_compile() {
+ # Do nothing
+ # The makefile just builds the documentation again
+ # Not even any install targets
+ return
+}
+
+src_install() {
+ doheader -r boost
+
+ use doc && HTML_DOCS+=( "${WORKDIR}"/"${MY_P}"-doc/. )
+ einstalldocs
+}