summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/yaml-cpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/yaml-cpp')
-rw-r--r--dev-cpp/yaml-cpp/Manifest2
-rw-r--r--dev-cpp/yaml-cpp/metadata.xml11
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.3.0.ebuild35
-rw-r--r--dev-cpp/yaml-cpp/yaml-cpp-0.5.1.ebuild34
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-cpp/yaml-cpp/Manifest b/dev-cpp/yaml-cpp/Manifest
new file mode 100644
index 000000000000..8b5a1bed5876
--- /dev/null
+++ b/dev-cpp/yaml-cpp/Manifest
@@ -0,0 +1,2 @@
+DIST yaml-cpp-0.3.0.tar.gz 82674 SHA256 2cd038b5a1583b6745e949e196fba525f6d0d5fd340566585fde24fc7e117b82 SHA512 1db7ef9ab717cf3185494dd40872d53948822bf0bb7a8039f5ccade77f29a7c1f37671627404d33f3213654d8e0582e6eaad139fd51f455a0d4d779bf467f43d WHIRLPOOL 106c5a3eda627651c49e1bcf9f22345fcaaaeb85efac4de7b7d103b0d2924ccb3c093dcd6ac03ccad7325d1f3faffc3165288e62bfa913eca21bfcb4eb3b26b9
+DIST yaml-cpp-0.5.1.tar.gz 118244 SHA256 3e7c9052b43d987d41819a203d97fc45de4eed3ec67e0fdb14265c3d11046f06 SHA512 3c6928684d603815c016d663af36be94507f2cccf167d6d8d7cd7dea3ea5f73ec88d62952a2b5d11796e40132857afcbbacd9eafd688f2dc11d0c339caf2e013 WHIRLPOOL 43c1998584fb8cc8b0954a1eba39aaffff18be074c5f1c84ac60df89adc84717007d8f6e67978da2e4f235365d820d7b2809f19eb3c67263ff936f44a9438546
diff --git a/dev-cpp/yaml-cpp/metadata.xml b/dev-cpp/yaml-cpp/metadata.xml
new file mode 100644
index 000000000000..40068b39f78f
--- /dev/null
+++ b/dev-cpp/yaml-cpp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>neurogeek@gentoo.org</email>
+ <name>Jesus Rivero</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">yaml-cpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.3.0.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.3.0.ebuild
new file mode 100644
index 000000000000..becb268db4b7
--- /dev/null
+++ b/dev-cpp/yaml-cpp/yaml-cpp-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="A YAML parser and emitter in C++"
+HOMEPAGE="http://code.google.com/p/yaml-cpp/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i \
+ -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
+ yaml-cpp.pc.cmake || die
+
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-cpp/yaml-cpp/yaml-cpp-0.5.1.ebuild b/dev-cpp/yaml-cpp/yaml-cpp-0.5.1.ebuild
new file mode 100644
index 000000000000..4c6a51814a4f
--- /dev/null
+++ b/dev-cpp/yaml-cpp/yaml-cpp-0.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A YAML parser and emitter in C++"
+HOMEPAGE="http://code.google.com/p/yaml-cpp/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.49.0-r2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's:INCLUDE_INSTALL_ROOT_DIR:INCLUDE_INSTALL_DIR:g' \
+ yaml-cpp.pc.cmake || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake-utils_src_configure
+}