summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <stefan.strogin@gmail.com>2019-02-20 23:40:43 +0200
committerAaron Bauman <bman@gentoo.org>2019-02-22 18:36:28 -0500
commit5d65b5571447c81a5c05c71c1d7b49fee9d06221 (patch)
treebaa321ad724752af34ebae3b4ba33932e0fc2d3d /dev-cpp
parentdev-cpp/commoncpp2: add patch for openssl-1.1 and libressl support (diff)
downloadgentoo-5d65b5571447c81a5c05c71c1d7b49fee9d06221.tar.gz
gentoo-5d65b5571447c81a5c05c71c1d7b49fee9d06221.tar.bz2
gentoo-5d65b5571447c81a5c05c71c1d7b49fee9d06221.zip
dev-cpp/commoncpp2: add USE=libressl
Closes: https://bugs.gentoo.org/678440 Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com> Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.8.1-r4.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.8.1-r4.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.8.1-r4.ebuild
index f5f40d898c1e..797bc478eb2f 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.8.1-r4.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.8.1-r4.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="https://www.gnu.org/software/commoncpp/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="debug doc examples ipv6 gnutls ssl static-libs"
+IUSE="debug doc examples gnutls ipv6 libressl ssl static-libs"
RDEPEND="
sys-libs/zlib
@@ -20,7 +20,10 @@ RDEPEND="
dev-libs/libgcrypt:0=
net-libs/gnutls:=
)
- !gnutls? ( dev-libs/openssl:0= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
)"
DEPEND="${RDEPEND}
doc? ( >=app-doc/doxygen-1.3.6 )"