summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-18 04:45:09 +0100
committerSam James <sam@gentoo.org>2021-08-18 04:45:32 +0100
commit633891ad5a4bc8e60599933427a55400ae5bcab4 (patch)
tree7f8aa5f88adcf9409f03b2f3cbcd91a8e32ede91 /dev-cpp
parentdev-cpp/nlohmann_json: add 3.10.0 (diff)
downloadgentoo-633891ad5a4bc8e60599933427a55400ae5bcab4.tar.gz
gentoo-633891ad5a4bc8e60599933427a55400ae5bcab4.tar.bz2
gentoo-633891ad5a4bc8e60599933427a55400ae5bcab4.zip
dev-cpp/nlohmann_json: use same test archive name for 3.9.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/nlohmann_json/Manifest1
-rw-r--r--dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild4
2 files changed, 3 insertions, 2 deletions
diff --git a/dev-cpp/nlohmann_json/Manifest b/dev-cpp/nlohmann_json/Manifest
index 2217acaec3a9..25ae070a9891 100644
--- a/dev-cpp/nlohmann_json/Manifest
+++ b/dev-cpp/nlohmann_json/Manifest
@@ -1,4 +1,3 @@
DIST nlohmann_json-3.10.0.tar.gz 7006504 BLAKE2B 2ccb2e50a46a8579b6a848f6fee35ad1ff11a1491157bdf5d343133f24d4468ddfabc4fe4e9909b47011d52b3604566d5d7e275f0731c8d91efd1e1b9c545ef2 SHA512 1531780110260ea4cd8fbe79d860f1ea46fa8377d520669f938ddb5f8a4b11fe550fc7d2d978a281d5ddcc511447d160a2f68c06583672496c57c6672a4036a1
-DIST nlohmann_json-3.9.1-testdata.tar.gz 112348454 BLAKE2B f0a47b41805bf1426f612e9a82efea2a3e5b1c15740c1c531d859e60dc5daeb85209b4fe363fd8fb84e3bbf01a2578c74538ba3e769726494047979f5a4d468d SHA512 d9af8419b837c592ec7519cd5772651c761078a9c43cf2a309cee55c323aee0df0c233fb58a07d5ee2e77492ac8b16398de234b387eae037a60e3c9ba5b08891
DIST nlohmann_json-3.9.1.tar.gz 6882818 BLAKE2B 97276dc2345ac2070ac2d30d0a2e1953bb2f6ecde437eaed87dad46c108daa4b21c662a047e7d4e7c180179df9e7dfb71f545f3e42b2528201630d9093539090 SHA512 e0eb4727bea993af984f832e069d03a21219befae0f24ee49e67a1144cf1e8428dcf2e37f683aedb8d14118545d5087f2b7d822a576944cef3e590a12be51642
DIST nlohmann_json-testdata-3.0.0.tar.gz 112348454 BLAKE2B f0a47b41805bf1426f612e9a82efea2a3e5b1c15740c1c531d859e60dc5daeb85209b4fe363fd8fb84e3bbf01a2578c74538ba3e769726494047979f5a4d468d SHA512 d9af8419b837c592ec7519cd5772651c761078a9c43cf2a309cee55c323aee0df0c233fb58a07d5ee2e77492ac8b16398de234b387eae037a60e3c9ba5b08891
diff --git a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
index ded1b4622890..727db8df498c 100644
--- a/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
+++ b/dev-cpp/nlohmann_json/nlohmann_json-3.9.1.ebuild
@@ -5,11 +5,13 @@ EAPI=7
inherit cmake
+# Check https://github.com/nlohmann/json/blob/develop/cmake/download_test_data.cmake to find test archive version
+TEST_VERSION="3.0.0"
DESCRIPTION="JSON for Modern C++"
HOMEPAGE="https://github.com/nlohmann/json https://nlohmann.github.io/json/"
SRC_URI="
https://github.com/nlohmann/json/archive/v${PV}.tar.gz -> ${P}.tar.gz
- test? ( https://github.com/nlohmann/json_test_data/archive/v3.0.0.tar.gz -> ${P}-testdata.tar.gz )"
+ test? ( https://github.com/nlohmann/json_test_data/archive/v${TEST_VERSION}.tar.gz -> ${PN}-testdata-${TEST_VERSION}.tar.gz )"
S="${WORKDIR}/json-${PV}"
LICENSE="MIT"