summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2021-08-04 09:06:15 +0100
committerIonen Wolkens <ionen@gentoo.org>2021-08-11 16:40:20 -0400
commita0e899e8abf1c05aa4b287fa6b3226b9df89f992 (patch)
tree4a9ce940904fcaf660278c778fcc949fd1cad0de /dev-cpp
parentdev-cpp/asio: drop old (diff)
downloadgentoo-a0e899e8abf1c05aa4b287fa6b3226b9df89f992.tar.gz
gentoo-a0e899e8abf1c05aa4b287fa6b3226b9df89f992.tar.bz2
gentoo-a0e899e8abf1c05aa4b287fa6b3226b9df89f992.zip
dev-cpp/asio: version 1.19.2
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/21875 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/Manifest1
-rw-r--r--dev-cpp/asio/asio-1.19.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-cpp/asio/Manifest b/dev-cpp/asio/Manifest
index e8f6e97d17fc..a3957aa83cd3 100644
--- a/dev-cpp/asio/Manifest
+++ b/dev-cpp/asio/Manifest
@@ -1,3 +1,4 @@
DIST asio-1.10.8.tar.bz2 1270332 BLAKE2B 97e4a6a7c8b4562f10af1d122e9b08c12d567fd0447d1951a907f47f77832dcd42df4cb9b5b392feaaa2ea7c79d8bedfcf12e3052957ec012d8bb6b4d1347eb5 SHA512 d870686d2b19bec9925c311f2f0fd370e9797bbad252176a80a998f9c322ecd502b5081826105712e7caf87c03c3e6b70a0e219019e5bff46077d6e8c3c6db09
DIST asio-1.17.0.tar.bz2 1694631 BLAKE2B 0463355eef1714604290be43247139ea0220c5614c3c280ccf6049b64a2bb920c9eb885cf5f00c7e007caf3b049fe5cd6589dad0cb23cda4994fd31c7ecd8102 SHA512 5978cbf452aff07d6d19a2e641824628f409ab74e2e1a964776dae4c586386149acea56e4c8aa1075b247d2ce566daad640c3bbd15e211df1f73fc7b02964353
DIST asio-1.19.1.tar.bz2 1842955 BLAKE2B d60c1f98ad563eb7c1b163baac3a5560be1cd712e6b21dedc367b547d62725f22c96cea2ebb4dce1e37163a540ae24d65e9ebc37cde0046c043e83685b7d80c9 SHA512 af4501fbd6965ef2efb1f71cd703dec9bb65aaa62243649899469b711f9260936bbce7d261a6bb0db5ca47b7bccb89f72b219b19a249171c18d0a30fb40607e2
+DIST asio-1.19.2.tar.bz2 1842597 BLAKE2B b2236c33432984ab660eba4c93be32374bb49f688a1e6a0711d7bac322cc4a7f817db209278f216468c6a72b9d3dd564cf298e1f49f8098c3fd9aec7acd66eb7 SHA512 07f9c29d8f02090b4d4b6a1867bcc07a8e9f3388556dff787ca3ba143022eeb63bfac0b5bc264076fed4db3b2e5ec6b7ff0ebefde40ba4753c832032a72d54cc
diff --git a/dev-cpp/asio/asio-1.19.2.ebuild b/dev-cpp/asio/asio-1.19.2.ebuild
new file mode 100644
index 000000000000..6a7d747959dd
--- /dev/null
+++ b/dev-cpp/asio/asio-1.19.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="https://think-async.com https://github.com/chriskohlhoff/asio"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/boost
+ dev-libs/openssl
+ )
+"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF || die
+ all:
+
+ install:
+
+ clean:
+ EOF
+ fi
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ default
+
+ if use examples; then
+ # Get rid of the object files
+ emake clean
+ dodoc -r src/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}