summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-11-19 15:32:57 -0500
committerBrian Evans <grknight@gentoo.org>2015-11-19 15:32:57 -0500
commit8a80f503396351f04f53c0cd83f912563d889f42 (patch)
tree38668053947eab6a522006b3f55b106efc5e164d /dev-db/mariadb-galera
parentapp-admin/salt: sync 9999 ebuild with current release (diff)
downloadgentoo-8a80f503396351f04f53c0cd83f912563d889f42.tar.gz
gentoo-8a80f503396351f04f53c0cd83f912563d889f42.tar.bz2
gentoo-8a80f503396351f04f53c0cd83f912563d889f42.zip
dev-db/mariadb-galera: Version bump
Package-Manager: portage-2.2.25
Diffstat (limited to 'dev-db/mariadb-galera')
-rw-r--r--dev-db/mariadb-galera/Manifest1
-rw-r--r--dev-db/mariadb-galera/mariadb-galera-10.0.22.ebuild136
2 files changed, 137 insertions, 0 deletions
diff --git a/dev-db/mariadb-galera/Manifest b/dev-db/mariadb-galera/Manifest
index 07b0e941babd..99f9c3725619 100644
--- a/dev-db/mariadb-galera/Manifest
+++ b/dev-db/mariadb-galera/Manifest
@@ -1,2 +1,3 @@
DIST mariadb-galera-10.0.21.tar.gz 56518164 SHA256 dc5385603257980ac2549a2c142e7eb41ab2bf60f9ca47ddfc1f6138b5138b58 SHA512 46d007b48a6f03bf5242d771d96a07ebf3f35af9c32d74bed37fb1d72b493d66db2007ec134be7e9d9aca5b2ccb968049a347fb1cfd86d8cc2da1408ff32b5dc WHIRLPOOL a3d5b118a1fe11fc07727ace130cb8766d47b1ae49926ec95fcf79e80250286286ccc02cb8f8c78ec63bcb0556d2f559cbaab0ff62bf721bdd27a49d219da981
+DIST mariadb-galera-10.0.22.tar.gz 56593286 SHA256 03707fe86add4ed3a1039d1c2d2a1eca768feef15bf8499d6a61bdeb0802de9e SHA512 4dd508293235fc786f1d3ada37b20284f591e16c50aea06514de3d5310f01ef22d01c8345226395ddccc0ee8c96b952a6e7b17f94b248cb6977bf40fff7c117f WHIRLPOOL 612f8910a9549aab4e77f1580570500fc4591d6f034728be55c2af8cd861e1170289c82db622cb34116aa0131c2ba89b32290fff5e863c96693ed1825eeaf070
DIST mysql-extras-20150717-1707Z.tar.bz2 1491956 SHA256 d67cc1e2c581ab7c57122b7d29864643869799893a95a158a18e14201d4ffc10 SHA512 3a7cb07773099e766f8e796d4e555d42874b85285cc2c7c60220370cc6aafc36a60eb340008637298d85d83f529e73392895a81c1438ffccff9eb8f354b29ba9 WHIRLPOOL 11e75f4b696e2547c1da40e69d8ab75df4bf7080426204c040632f24846407b07d71061c09c4ff4a1d21a9d14a94769d8f8ef62421d0aecd99efe832caf4dd22
diff --git a/dev-db/mariadb-galera/mariadb-galera-10.0.22.ebuild b/dev-db/mariadb-galera/mariadb-galera-10.0.22.ebuild
new file mode 100644
index 000000000000..a420f7b219d4
--- /dev/null
+++ b/dev-db/mariadb-galera/mariadb-galera-10.0.22.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+MY_EXTRAS_VER="20150717-1707Z"
+WSREP_REVISION="25"
+HAS_TOOLS_PATCH="1"
+SUBSLOT="18"
+
+inherit toolchain-funcs mysql-multilib
+# only to make repoman happy. it is really set in the eclass
+IUSE="$IUSE"
+
+# REMEMBER: also update eclass/mysql*.eclass before committing!
+KEYWORDS="~amd64 ~x86"
+
+# When MY_EXTRAS is bumped, the index should be revised to exclude these.
+EPATCH_EXCLUDE=''
+
+DEPEND="|| ( >=sys-devel/gcc-3.4.6 >=sys-devel/gcc-apple-4.0 )"
+RDEPEND="${RDEPEND}"
+
+# Please do not add a naive src_unpack to this ebuild
+# If you want to add a single patch, copy the ebuild to an overlay
+# and create your own mysql-extras tarball, looking at 000_index.txt
+
+# Official test instructions:
+# USE='client-libs embedded extraengine perl server openssl static-libs tools' \
+# FEATURES='test userpriv -usersandbox' \
+# ebuild mariadb-galera-X.X.XX.ebuild \
+# digest clean package
+multilib_src_test() {
+
+ if ! multilib_is_native_abi ; then
+ einfo "Server tests not available on non-native abi".
+ return 0;
+ fi
+
+ local TESTDIR="${BUILD_DIR}/mysql-test"
+ local retstatus_unit
+ local retstatus_tests
+
+ # Bug #213475 - MySQL _will_ object strenously if your machine is named
+ # localhost. Also causes weird failures.
+ [[ "${HOSTNAME}" == "localhost" ]] && die "Your machine must NOT be named localhost"
+
+ if use server ; then
+
+ if [[ $UID -eq 0 ]]; then
+ die "Testing with FEATURES=-userpriv is no longer supported by upstream. Tests MUST be run as non-root."
+ fi
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ addpredict /this-dir-does-not-exist/t9.MYI
+
+ # Run CTest (test-units)
+ cmake-utils_src_test
+ retstatus_unit=$?
+ [[ $retstatus_unit -eq 0 ]] || eerror "test-unit failed"
+
+ # Ensure that parallel runs don't die
+ export MTR_BUILD_THREAD="$((${RANDOM} % 100))"
+ # Enable parallel testing, auto will try to detect number of cores
+ # You may set this by hand.
+ # The default maximum is 8 unless MTR_MAX_PARALLEL is increased
+ export MTR_PARALLEL="${MTR_PARALLEL:-auto}"
+
+ # create directories because mysqladmin might right out of order
+ mkdir -p "${T}"/var-tests{,/log}
+
+ # Create a symlink to provided binaries so the tests can find them when client-libs is off
+ if ! use client-libs ; then
+ ln -srf /usr/bin/my_print_defaults "${BUILD_DIR}/client/my_print_defaults" || die
+ ln -srf /usr/bin/perror "${BUILD_DIR}/client/perror" || die
+ mysql-multilib_disable_test main.perror "String mismatch due to not building local perror"
+ fi
+
+ # These are failing in MariaDB 10.0 for now and are believed to be
+ # false positives:
+ #
+ # main.information_schema, binlog.binlog_statement_insert_delayed,
+ # main.mysqld--help, funcs_1.is_triggers, funcs_1.is_tables_mysql,
+ # funcs_1.is_columns_mysql, main.bootstrap
+ # fails due to USE=-latin1 / utf8 default
+ #
+ # main.mysql_client_test, main.mysql_client_test_nonblock
+ # main.mysql_client_test_comp:
+ # segfaults at random under Portage only, suspect resource limits.
+ #
+ # wsrep.variables:
+ # Expects the sys-cluster/galera library to be installed and configured
+ #
+ # wsrep.foreign_key:
+ # Issues a configuration deprecation warning which does not affect data
+ #
+
+ for t in main.mysql_client_test main.mysql_client_test_nonblock \
+ main.mysql_client_test_comp main.bootstrap \
+ binlog.binlog_statement_insert_delayed main.information_schema \
+ main.mysqld--help wsrep.variables wsrep.foreign_key \
+ funcs_1.is_triggers funcs_1.is_tables_mysql funcs_1.is_columns_mysql ; do
+ mysql-multilib_disable_test "$t" "False positives in Gentoo"
+ done
+
+ # Run mysql tests
+ pushd "${TESTDIR}"
+
+ # run mysql-test tests
+ # The PATH addition is required for the galera suite to find the sst scripts
+ WSREP_LOG_DIR="${T}/var-tests/wsrep" \
+ PATH="${BUILD_DIR}/scripts:${PATH}" \
+ perl mysql-test-run.pl --force --vardir="${T}/var-tests"
+ retstatus_tests=$?
+ [[ $retstatus_tests -eq 0 ]] || eerror "tests failed"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ popd
+
+ # Cleanup is important for these testcases.
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+
+ failures=""
+ [[ $retstatus_unit -eq 0 ]] || failures="${failures} test-unit"
+ [[ $retstatus_tests -eq 0 ]] || failures="${failures} tests"
+ has usersandbox $FEATURES && eerror "Some tests may fail with FEATURES=usersandbox"
+
+ [[ -z "$failures" ]] || die "Test failures: $failures"
+ einfo "Tests successfully completed"
+ else
+
+ einfo "Skipping server tests due to minimal build."
+ fi
+}