summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Satula <maksym.satula@gmail.com>2019-01-12 15:42:16 -0500
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-09 10:52:00 +0100
commitc81f2f6103a468f1cc5f42f6b6f111f504050c7d (patch)
tree6ea8d94136ffda7526e69bea703de31439c894a2 /dev-db/ocp/ocp-0.3.ebuild
parentkde-misc/tellico: remove unused patches (diff)
downloadgentoo-c81f2f6103a468f1cc5f42f6b6f111f504050c7d.tar.gz
gentoo-c81f2f6103a468f1cc5f42f6b6f111f504050c7d.tar.bz2
gentoo-c81f2f6103a468f1cc5f42f6b6f111f504050c7d.zip
dev-db/ocp: bump to 0.3
Bump to EAPI=7 Replace a dependency on a transitional package `dev-db/oracle-instantclient-basic` with a newer `dev-db/oracle-instantclient` package https://bugs.gentoo.org/show_bug.cgi?id=524922#c12 Signed-off-by: Max Satula <maksym.satula@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10814 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-db/ocp/ocp-0.3.ebuild')
-rw-r--r--dev-db/ocp/ocp-0.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-db/ocp/ocp-0.3.ebuild b/dev-db/ocp/ocp-0.3.ebuild
new file mode 100644
index 000000000000..5c6591bf5df3
--- /dev/null
+++ b/dev-db/ocp/ocp-0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Oracle copy tool"
+HOMEPAGE="https://github.com/maxsatula/ocp"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-db/oracle-instantclient
+ dev-libs/popt
+ sys-libs/zlib"
+DEPEND="
+ dev-db/oracle-instantclient[sdk]
+ ${RDEPEND}"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *9999 ]] ; then
+ eautoreconf
+ fi
+}