summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-02-02 07:37:43 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-02-02 07:38:47 +0000
commit8dfd0739801d9066f7c5227e35990ba9d208a701 (patch)
tree1e87ae8a50dbc39eec518c92a956522c7e20dc62 /dev-db/postgis
parentprofiles/arch/hppa: stable-mask net-analyzer/ifstat[snmp] (diff)
downloadgentoo-8dfd0739801d9066f7c5227e35990ba9d208a701.tar.gz
gentoo-8dfd0739801d9066f7c5227e35990ba9d208a701.tar.bz2
gentoo-8dfd0739801d9066f7c5227e35990ba9d208a701.zip
dev-db/postgis: Bump to 3.1.5
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-db/postgis')
-rw-r--r--dev-db/postgis/Manifest1
-rw-r--r--dev-db/postgis/postgis-3.1.5.ebuild143
2 files changed, 144 insertions, 0 deletions
diff --git a/dev-db/postgis/Manifest b/dev-db/postgis/Manifest
index 606b0514a749..d26a55fc59c9 100644
--- a/dev-db/postgis/Manifest
+++ b/dev-db/postgis/Manifest
@@ -5,4 +5,5 @@ DIST postgis-3.1.1.tar.gz 17261826 BLAKE2B a14bdce3773f8cc50c72880d9b8158c32b546
DIST postgis-3.1.2.tar.gz 17266501 BLAKE2B acc65e3ab70667c57a71bcb9c7bbfc382f8a6038ceb0e91aac07e36fb6b4cb6365aa968b30af13eda8292410cc1b567d871970e6cb7dfaadb454147224f9b834 SHA512 df9d2fa118987e29acd635912a708e643770ad3df82c098f8129f11ab07a9eafde969302d2d2e59a68fea6fc7312fe768a231dd4cb5de7002c418725da75848a
DIST postgis-3.1.3.tar.gz 17273487 BLAKE2B 603be66476037fca5e75b00079a26b4beaa50f0af0626f89660f17da398576d929574cb363c4177877d9c8db5459f7eac964b85796cd93b0d0c6ff2462d7ad3f SHA512 525c982de6b5888d1f4a4f6d2cca5dfa945d8899d8038b1d62ce222e0149c4ab26a2a3602bb8c85e89ce22b3d5b20d278fc4f841144f4b0d19e6de4f48d819ad
DIST postgis-3.1.4.tar.gz 17269391 BLAKE2B 6070fb72c777f8baf9c520ec51cf436837fffb54f21af5b4cf800940240f2fb9fcee162b2d3817cbfd4e60c2cef37eb4cf902d9e9f065e537d8d9b8ec965bef3 SHA512 afd84b45b146bdae310580fc9f8a878dd658f9e74f99c41f5d143f32974d5f5017ab4190855dcaea915a31ac2a78d34bf5561f206965264de3252f2c2ac57683
+DIST postgis-3.1.5.tar.gz 17282333 BLAKE2B 3abe3b24ad0b8a9621c206f881a920ec4e37aa75ccc68ab8e4a43a372bb9047613c81d375051a948999068595de04f14bf4f0b7921b3f3894ff77a9d8c1c3063 SHA512 640196f4c983aeb1d661d98e099f4e2a47f32b15bfde21479b8fdb2aa5d12b4c564b0962973ec1a8dd64fbfac7cd7bc94d84376935294f23ba31d7501fe64a06
DIST postgis-3.2.0.tar.gz 16884722 BLAKE2B 118ae754199521e46508b404275bfe323465e5543ad8351d3dec3582800f6c475c30333b35ad48aac373f9d8e3875790c58858f638ee4ecb7465764703d07d40 SHA512 b49b2fbb88ec07981c0fd05400ad807e85553164023a4b47326c21f48b4e07827a183676c497ad6823dc3a6b97518e1d40906826b8a91739c96966d62858b2b5
diff --git a/dev-db/postgis/postgis-3.1.5.ebuild b/dev-db/postgis/postgis-3.1.5.ebuild
new file mode 100644
index 000000000000..a5c0c0e58438
--- /dev/null
+++ b/dev-db/postgis/postgis-3.1.5.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+POSTGRES_COMPAT=( 9.6 {10..14} )
+POSTGRES_USEDEP="server"
+inherit autotools postgres-multi toolchain-funcs
+
+MY_P="${PN}-$(ver_rs 3 '')"
+
+if [[ ${PV} = *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.osgeo.org/gitea/postgis/postgis.git"
+else
+ PGIS="$(ver_cut 1-2)"
+ SRC_URI="https://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Geographic Objects for PostgreSQL"
+HOMEPAGE="https://postgis.net"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="address-standardizer doc gtk static-libs topology"
+
+REQUIRED_USE="${POSTGRES_REQ_USE}"
+
+# Needs a running psql instance, doesn't work out of the box
+RESTRICT="test"
+
+RDEPEND="${POSTGRES_DEP}
+ dev-libs/json-c:=
+ dev-libs/libxml2:2
+ dev-libs/protobuf-c:=
+ >=sci-libs/geos-3.9.0
+ >=sci-libs/proj-4.9.0:=
+ >=sci-libs/gdal-1.10.0:=
+ address-standardizer? ( dev-libs/libpcre )
+ gtk? ( x11-libs/gtk+:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.5
+ dev-libs/libxslt
+ virtual/imagemagick-tools[png]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.0-arflags.patch"
+ "${FILESDIR}/${PN}-3.0.3-avoid-calling-ar-directly.patch"
+ "${FILESDIR}/${PN}-3.0.3-detect-only-stdc.patch"
+ "${FILESDIR}/${PN}-3.0.3-try-other-cpp-names.patch"
+)
+
+src_prepare() {
+ default
+
+ if [[ ${PV} = *9999* ]] ; then
+ source "${S}"/Version.config
+ PGIS="${POSTGIS_MAJOR_VERSION}.${POSTGIS_MINOR_VERSION}"
+ fi
+
+ # These modules are built using the same *FLAGS that were used to build
+ # dev-db/postgresql. The right thing to do is to ignore the current
+ # *FLAGS settings.
+ QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
+
+ # bug #775968
+ touch build-aux/ar-lib || die
+
+ local AT_M4DIR="macros"
+ eautoreconf
+
+ postgres-multi_src_prepare
+}
+
+src_configure() {
+ export CPP=$(tc-getCPP)
+
+ local myeconfargs=(
+ $(use_with address-standardizer)
+ $(use_with gtk gui)
+ $(use_with topology)
+ )
+ postgres-multi_foreach econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ postgres-multi_foreach emake
+ postgres-multi_foreach emake -C topology
+
+ if use doc ; then
+ postgres-multi_foreach emake comments
+ postgres-multi_foreach emake cheatsheets
+ postgres-multi_forbest emake -C doc html
+ fi
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+ postgres-multi_foreach emake -C topology DESTDIR="${D}" install
+ postgres-multi_forbest dobin ./utils/postgis_restore.pl
+
+ dodoc CREDITS TODO loader/README.* doc/*txt
+
+ docinto topology
+ dodoc topology/{TODO,README}
+
+ if use doc ; then
+ postgres-multi_foreach emake DESTDIR="${D}" comments-install
+
+ docinto html
+ postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
+
+ docinto html/images
+ postgres-multi_forbest dodoc doc/html/images/*
+ fi
+
+ use static-libs || find "${ED}" -name '*.a' -delete
+}
+
+pkg_postinst() {
+ ebegin "Refreshing PostgreSQL symlinks"
+ postgresql-config update
+ eend $?
+
+ local base_uri="https://postgis.net/docs/manual-"
+ if [[ ${PV} = *9999* ]] ; then
+ base_uri+="dev"
+ else
+ base_uri+="${PGIS}"
+ fi
+
+ elog "To finish installing PostGIS, follow the directions detailed at:"
+ elog "${base_uri}/postgis_installation.html#create_new_db_extensions"
+}