summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-09-07 06:24:29 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-09-07 06:24:29 -0400
commit4d36eed6c7bea83bb427a9afddfee91622a42526 (patch)
tree8c2cd36b37eceb41f37f957f944d1b4720728bd9 /dev-db/slony1
parentdev-lang/php: stable 7.0.21 for sparc, bug #624052 (tested by Dakon) (diff)
downloadgentoo-4d36eed6c7bea83bb427a9afddfee91622a42526.tar.gz
gentoo-4d36eed6c7bea83bb427a9afddfee91622a42526.tar.bz2
gentoo-4d36eed6c7bea83bb427a9afddfee91622a42526.zip
dev-db/slony1: 2.2.6 Version Bump
2.2.6 brings with it support for PostgreSQL 10. Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-db/slony1')
-rw-r--r--dev-db/slony1/Manifest2
-rw-r--r--dev-db/slony1/slony1-2.2.6.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-db/slony1/Manifest b/dev-db/slony1/Manifest
index 9eebb21fd0d9..e65b378e0248 100644
--- a/dev-db/slony1/Manifest
+++ b/dev-db/slony1/Manifest
@@ -14,3 +14,5 @@ DIST slony1-2.2.4-docs.tar.bz2 1448892 SHA256 0417194a9245e615dedc00ef463e1357df
DIST slony1-2.2.4.tar.bz2 1467776 SHA256 846a878f50de520d151e7f76a66d9b9845e94beb8820727bf84ab522a73e65b5 SHA512 951ecb07ae9f8478affeeb5c968530f597c203b24341b600057107f53adcdc53afce7dd21893700bb8d0ebd26fceb0ebc60917c9f5992b315a2bce47a1d57867 WHIRLPOOL 8a29c24e735f140a915779b81a9f8b5aeaa7c75a4dc122fb8ba322c10aa8be8dfe38ec853f38a503f595b7685759241a169c430cf2a9ef6ddb7ebaa1b3f4448e
DIST slony1-2.2.5-docs.tar.bz2 1449297 SHA256 7afd749215ca63d5f808c2c199096d4d665923b277edaf75b01e4a8bfdf90472 SHA512 cdd08fcea56f29e8e944cd975b613747cfcab75e70d88afdec79b2ede96dc2d1b35b294cd12c522780e513b4cd26c43da401d9570ca67759dbb2271797a380ac WHIRLPOOL 18206b34d03cb685389398f00d681707471b0cbf9cb3dcefb4cc99b24c35f37c10acc32e573a1c255f85881700efde9e1c8c3948596ebc84fbf5254af866b147
DIST slony1-2.2.5.tar.bz2 1466439 SHA256 6f6dbd9619c615ed68bf6341a8158e42fc0adf6f5b609e6f8e4a0a0e37815241 SHA512 06c5d8c136b1560aa6a3b1b7bfbad09fb6bbff7e3c530ceaf0279d4564dd1518c69647368deac9eb19ea5059a2d78fef26f62bd34315f5f3415ca0f5cb0992aa WHIRLPOOL 3b9b96c41fbe9da03362a866d3bc81da38be82625a9d25378b69cf322ba6aba05fc15f0725ba3f878e4a9d2b5e6609e50ad6d602f480e6e1482d1953135ecb14
+DIST slony1-2.2.6-docs.tar.bz2 1450956 SHA256 418030209a677845127871eb37d324317acd68a5cfda1e0301ec6f0776c39118 SHA512 b5a870d5688ca24c0a9012d7da539917c74ee697f1b1ae663ead3cb1032345c0d8f5fc5bddc2ca2fec5d738fb9ca74822343cce8739b3b4b478928f26d214a0d WHIRLPOOL bae6e88360d3026feed4029ca9b222966631a3b5608876072de4a1955c9607762dae434281fa3762184e133b5aa2f9a3dff264f1e15caaad7c51ea4e73c778fa
+DIST slony1-2.2.6.tar.bz2 1465709 SHA256 79cf246741bc3f95f6890f2dbed5712d6e5a127bf1f442cf8af102d23de0919c SHA512 5aeadb9ed72b83d303596e4f8513409a1f826f25fe283ca6aa969a7563172bbc5f5360f876fa87780f6a6fc70cb55688a2daf678b9cf91972a3c403cb76184b8 WHIRLPOOL 464c52f2063abcd33a0df0f266b538605584accff5461fea2780df96290c4607783b3a49d636f5f8d83622a6f1b5bbbac463be6f829a7c85f06ba6f406859007
diff --git a/dev-db/slony1/slony1-2.2.6.ebuild b/dev-db/slony1/slony1-2.2.6.ebuild
new file mode 100644
index 000000000000..59ee59bcec1c
--- /dev/null
+++ b/dev-db/slony1/slony1-2.2.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+POSTGRES_COMPAT=( 9.{2..6} 10 )
+POSTGRES_USEDEP="server,threads"
+
+inherit eutils postgres-multi versionator
+
+IUSE="doc perl"
+
+DESCRIPTION="A replication system for the PostgreSQL Database Management System"
+HOMEPAGE="http://slony.info/"
+
+# ${P}-docs.tar.bz2 contains man pages as well as additional documentation
+MAJ_PV=$(get_version_component_range 1-2)
+SRC_URI="http://main.slony.info/downloads/${MAJ_PV}/source/${P}.tar.bz2
+ http://main.slony.info/downloads/${MAJ_PV}/source/${P}-docs.tar.bz2"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="${POSTGRES_DEP}
+ perl? ( dev-perl/DBD-Pg )
+"
+
+RDEPEND=${DEPEND}
+
+REQUIRE_USE="${POSTGRES_REQ_USE}"
+
+src_configure() {
+ local slot_bin_dir="/usr/$(get_libdir)/postgresql-@PG_SLOT@/bin"
+ use perl && myconf=" --with-perltools=\"${slot_bin_dir}\""
+ postgres-multi_foreach econf ${myconf} \
+ --with-pgconfigdir="${slot_bin_dir}" \
+ --with-slonybindir="${slot_bin_dir}"
+}
+
+src_install() {
+ postgres-multi_foreach emake DESTDIR="${D}" install
+
+ dodoc INSTALL README SAMPLE TODO UPGRADING share/slon.conf-sample
+
+ if use doc ; then
+ cd "${S}"/doc
+ dohtml -r *
+ fi
+
+ newinitd "${FILESDIR}"/slony1.init slony1
+ newconfd "${FILESDIR}"/slony1.conf slony1
+}
+
+pkg_postinst() {
+ # Slony-I installs its executables into a directory that is
+ # processed by the PostgreSQL eselect module. Call it here so that
+ # the symlinks will be created.
+ ebegin "Refreshing PostgreSQL $(postgresql-config show) symlinks"
+ postgresql-config update
+ eend $?
+}