summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-25 16:01:28 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-25 16:01:28 +0200
commitf43a0fb94d5e378286c4e9640695a00f06d8f53a (patch)
tree2ad19f37acbf0504bf46af002f7d00e97ba1971d /dev-db
parentwww-apps/hugo: Version bump to 0.45.1 (diff)
downloadgentoo-f43a0fb94d5e378286c4e9640695a00f06d8f53a.tar.gz
gentoo-f43a0fb94d5e378286c4e9640695a00f06d8f53a.tar.bz2
gentoo-f43a0fb94d5e378286c4e9640695a00f06d8f53a.zip
dev-db/etcd: Version bump to 3.3.9
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/etcd/Manifest1
-rw-r--r--dev-db/etcd/etcd-3.3.9.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-db/etcd/Manifest b/dev-db/etcd/Manifest
index 1af34faf1d2f..ee770b0ae7da 100644
--- a/dev-db/etcd/Manifest
+++ b/dev-db/etcd/Manifest
@@ -1,2 +1,3 @@
DIST etcd-3.2.22.tar.gz 3243190 BLAKE2B 165eff928f5f5419d02ef07aebb5160ac5473721a1e27ee1eb2a6b1e5ff775f2f7254ddfc20dec14c28cd2de68966e7b8521fb29c7242a420fa61d226e16b3ba SHA512 7a32dce894ca643f0c51267edc0fba2524c197f0ac3185c6acd22879cd58236f6bcc9c3825d9b8f196255c8bf6aed1b893e1a62124c946f95b4832b409a6b4c0
DIST etcd-3.3.8.tar.gz 3518826 BLAKE2B 4d8ac66022c63250e37871a40041a799a21361f005f5ff259711ea7a0557acbe7f3920815ff0b5193499177e42c306ff8383192e7d4c31c94439d9461dea979f SHA512 c3a3f9ffb614e383854bf5a8819e3dcad8f02b267d74197685b546c856e983c92f8c459185c327adf7ba3d0326e2058fb34caac0896d78494cde86c3f7e04ac7
+DIST etcd-3.3.9.tar.gz 3521457 BLAKE2B 4c8ae96744b93efe19626225ccd5deca19e9e6bd18d87778e9ba1c207e288ed66d79410bc51bb8c7621c0bf261012ca95d86cd9d307655688a6026a46d891c34 SHA512 1e5143060d04138eee68250b57f73bf7a6fdb4ca085443df067b12a4824d24b591e42f3d890a285912126447e8b28c0e6bcee58b8633e01dcf9ae5764ff531a6
diff --git a/dev-db/etcd/etcd-3.3.9.ebuild b/dev-db/etcd/etcd-3.3.9.ebuild
new file mode 100644
index 000000000000..88b1e478fe0a
--- /dev/null
+++ b/dev-db/etcd/etcd-3.3.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit user systemd golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+EGO_PN="github.com/coreos/etcd"
+MY_PV="${PV/_rc/-rc.}"
+DESCRIPTION="Highly-available key value store for shared configuration and service discovery"
+HOMEPAGE="https://github.com/coreos/etcd"
+SRC_URI="https://${EGO_PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc +server"
+DEPEND=">=dev-lang/go-1.9:="
+RDEPEND="!dev-db/etcdctl"
+
+src_prepare() {
+ default
+ sed -e 's|GIT_SHA=.*|GIT_SHA=v${PV}|'\
+ -i "${S}"/src/${EGO_PN}/build || die
+}
+
+pkg_setup() {
+ if use server; then
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+ fi
+}
+
+src_compile() {
+ export GOPATH=${S}
+ pushd src/${EGO_PN} || die
+ ./build || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin bin/etcdctl
+ use doc && dodoc -r Documentation
+ if use server; then
+ insinto /etc/${PN}
+ doins "${FILESDIR}/${PN}.conf"
+ dobin bin/etcd
+ dodoc README.md
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d.conf" ${PN}.conf
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ keepdir /var/lib/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN}
+ fperms 0700 /var/lib/${PN}
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ fperms 755 /var/log/${PN}
+ fi
+ popd || die
+}
+
+src_test() {
+ pushd src/${EGO_PN} || die
+ ./test || die
+ popd || die
+}