summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2015-09-18 07:07:49 +0200
committerChristoph Mende <angelos@gentoo.org>2015-09-18 07:18:38 +0200
commitee1df7c912f72e0ed4f9dcbdb10e9cb2f40514de (patch)
treee690ff82c0293f5f34fad7ac17fcf2c27838e87b /dev-dotnet/dbus-sharp-glib
parentdev-dotnet/dbus-sharp-glib: fix dependency on dbus-sharp (diff)
downloadgentoo-ee1df7c912f72e0ed4f9dcbdb10e9cb2f40514de.tar.gz
gentoo-ee1df7c912f72e0ed4f9dcbdb10e9cb2f40514de.tar.bz2
gentoo-ee1df7c912f72e0ed4f9dcbdb10e9cb2f40514de.zip
dev-dotnet/dbus-sharp-glib: bump EAPI to 5, migrate to mono-env, add support for mono-4
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-dotnet/dbus-sharp-glib')
-rw-r--r--dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.5.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.5.0-r1.ebuild b/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..bcc9c7e606cf
--- /dev/null
+++ b/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.5.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools mono-env
+
+DESCRIPTION="D-Bus for .NET: GLib integration module"
+HOMEPAGE="https://github.com/mono/dbus-sharp"
+SRC_URI="mirror://github/mono/dbus-sharp/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1.0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono
+ >=dev-dotnet/dbus-sharp-0.7:1.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS README"
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's/gmcs/mcs/' configure.ac || die
+ eautoreconf
+}