summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/taglib-sharp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/taglib-sharp')
-rw-r--r--dev-dotnet/taglib-sharp/Manifest2
-rw-r--r--dev-dotnet/taglib-sharp/metadata.xml5
-rw-r--r--dev-dotnet/taglib-sharp/taglib-sharp-2.0.4.0.ebuild31
-rw-r--r--dev-dotnet/taglib-sharp/taglib-sharp-2.1.0.0.ebuild32
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-dotnet/taglib-sharp/Manifest b/dev-dotnet/taglib-sharp/Manifest
new file mode 100644
index 000000000000..59bf5d483072
--- /dev/null
+++ b/dev-dotnet/taglib-sharp/Manifest
@@ -0,0 +1,2 @@
+DIST taglib-sharp-2.0.4.0.tar.bz2 505231 SHA256 1acb310ec555e47e053ae9bd7299495c1f05e729d4e32d48ade8847233008040 SHA512 0c10edd08b5ff7dc4dc39e2e1e72a67eca17c2dbbce0d29a798a1c782de3c87e19a276d919a4dafd2518d58af23b3dd037a1e02ef49bc2ec2483e6cb53ce56a5 WHIRLPOOL c63f26dda644d87676b31f659e4055d35182d794ecc37853be80e12d694e605fb46d94372b88207e5915725bb74a046caa8ab5efa04a2d566b856a59fe818981
+DIST taglib-sharp-2.1.0.0.tar.bz2 514406 SHA256 a2a74092eddec23a47a1cf2e569e52bb784b6ea26fe640f4fac5959acb4da2a8 SHA512 59c3ab4086c6aa40d277dd146b15f5e2d1aca07a7315cd6a3bdc20849f11c4077a06051c602f254b5edd1aa83b00e37d5871a468795c26826235d5c623e74957 WHIRLPOOL 85ac5a68f1499b6e4ea1ae6de692d75631d4a5679ab5fb80bb6860f7e2370d555b96c7cfb7c053446041c942f9a51332ce0f846b963e8574c6ddcce6e4147d33
diff --git a/dev-dotnet/taglib-sharp/metadata.xml b/dev-dotnet/taglib-sharp/metadata.xml
new file mode 100644
index 000000000000..e85974a7fa17
--- /dev/null
+++ b/dev-dotnet/taglib-sharp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/taglib-sharp/taglib-sharp-2.0.4.0.ebuild b/dev-dotnet/taglib-sharp/taglib-sharp-2.0.4.0.ebuild
new file mode 100644
index 000000000000..aa5d30bbef37
--- /dev/null
+++ b/dev-dotnet/taglib-sharp/taglib-sharp-2.0.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit mono
+
+DESCRIPTION="Taglib# 2.0 - Managed tag reader/writer"
+HOMEPAGE="http://download.banshee.fm/taglib-sharp/"
+SRC_URI="http://download.banshee-project.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ sed -i -e "s:docs::" \
+ -e "s:examples::" \
+ Makefile.in || die "sedding sense into makefiles failed"
+}
+
+src_configure() {
+ econf --disable-docs
+}
diff --git a/dev-dotnet/taglib-sharp/taglib-sharp-2.1.0.0.ebuild b/dev-dotnet/taglib-sharp/taglib-sharp-2.1.0.0.ebuild
new file mode 100644
index 000000000000..9f9723e55564
--- /dev/null
+++ b/dev-dotnet/taglib-sharp/taglib-sharp-2.1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit mono
+
+DESCRIPTION="Taglib# 2.0 - Managed tag reader/writer"
+HOMEPAGE="http://download.banshee.fm/taglib-sharp/"
+SRC_URI="http://download.banshee-project.org/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ sed -i -e "s:docs::" \
+ -e "s:examples::" \
+ Makefile.in || die "sedding sense into makefiles failed"
+}
+
+src_configure() {
+ econf --disable-docs
+}