summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/gnusim8085
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/gnusim8085')
-rw-r--r--dev-embedded/gnusim8085/Manifest1
-rw-r--r--dev-embedded/gnusim8085/files/gnusim8085-1.3.7-cflags.patch13
-rw-r--r--dev-embedded/gnusim8085/files/gnusim8085-1.3.7-docs.patch22
-rw-r--r--dev-embedded/gnusim8085/gnusim8085-1.3.7.ebuild46
-rw-r--r--dev-embedded/gnusim8085/metadata.xml8
5 files changed, 90 insertions, 0 deletions
diff --git a/dev-embedded/gnusim8085/Manifest b/dev-embedded/gnusim8085/Manifest
new file mode 100644
index 000000000000..e2ca248c99ee
--- /dev/null
+++ b/dev-embedded/gnusim8085/Manifest
@@ -0,0 +1 @@
+DIST gnusim8085-1.3.7.tar.gz 365127 SHA256 e09b56089276eed91fb9df3c1e7e2aa4bf091859cfc62612521b45617167d525 SHA512 b1b701ef3292c2b3ea7a599f450ee495fdec730fa53e2ad9ea27c716a7de61d503f32345ed3cf6eeef3ef698ed4f0b957cb7ae207df0bee46363e76b5176b822 WHIRLPOOL 06c33af76c75eec7693180f411e83b174049a77ada4c9bda4da05bbb1e7db1df1ba43ba2436b5ec105f61e5182852e9e0f9c3b6e93e2e660686a79d9bbb4f1ed
diff --git a/dev-embedded/gnusim8085/files/gnusim8085-1.3.7-cflags.patch b/dev-embedded/gnusim8085/files/gnusim8085-1.3.7-cflags.patch
new file mode 100644
index 000000000000..ce118779ce01
--- /dev/null
+++ b/dev-embedded/gnusim8085/files/gnusim8085-1.3.7-cflags.patch
@@ -0,0 +1,13 @@
+--- gnusim8085-1.3.7/src/Makefile.am.orig
++++ gnusim8085-1.3.7/src/Makefile.am
+@@ -11,9 +11,7 @@
+
+ gnusim8085_CFLAGS =\
+ -DPACKAGE_DOC_DIR=\"$(docdir)\"\
+- -Wall\
+- -O1\
+- -g
++ -Wall
+
+ if WIN32
+ gnusim8085_CFLAGS += \
diff --git a/dev-embedded/gnusim8085/files/gnusim8085-1.3.7-docs.patch b/dev-embedded/gnusim8085/files/gnusim8085-1.3.7-docs.patch
new file mode 100644
index 000000000000..6ae26b892db4
--- /dev/null
+++ b/dev-embedded/gnusim8085/files/gnusim8085-1.3.7-docs.patch
@@ -0,0 +1,22 @@
+--- gnusim8085-1.3.7/Makefile.am.orig
++++ gnusim8085-1.3.7/Makefile.am
+@@ -3,17 +3,9 @@
+ ## If you don't want it to overwrite it,
+ ## Please disable it in the Anjuta project configuration
+
+-SUBDIRS = po src pixmaps doc data
++SUBDIRS = po src pixmaps data
+
+-gnusim8085_docdir = $(docdir)
+-gnusim8085_doc_DATA = \
+- README\
+- AUTHORS\
+- NEWS\
+- TODO\
+- ABOUT-NLS
+-
+-EXTRA_DIST = config.rpath m4/ChangeLog $(gnusim8085doc_DATA)
++EXTRA_DIST = config.rpath m4/ChangeLog
+
+ DISTCLEANFILES = *.exe *.gz
+
diff --git a/dev-embedded/gnusim8085/gnusim8085-1.3.7.ebuild b/dev-embedded/gnusim8085/gnusim8085-1.3.7.ebuild
new file mode 100644
index 000000000000..7415201b7c56
--- /dev/null
+++ b/dev-embedded/gnusim8085/gnusim8085-1.3.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils autotools
+
+DESCRIPTION="A GTK2 8085 Simulator"
+HOMEPAGE="http://gnusim8085.org"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls examples"
+
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ x11-libs/gdk-pixbuf:2
+ dev-libs/glib:2
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-docs.patch
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+ doman doc/gnusim8085.1
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/examples/*.asm doc/asm-guide.txt
+ fi
+}
diff --git a/dev-embedded/gnusim8085/metadata.xml b/dev-embedded/gnusim8085/metadata.xml
new file mode 100644
index 000000000000..11f8bc9daa48
--- /dev/null
+++ b/dev-embedded/gnusim8085/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-embedded</herd>
+ <upstream>
+ <remote-id type="launchpad">gnusim8085</remote-id>
+ </upstream>
+</pkgmetadata>