summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/sgpp-lite-arm-linux-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/sgpp-lite-arm-linux-bin')
-rw-r--r--dev-embedded/sgpp-lite-arm-linux-bin/Manifest1
-rw-r--r--dev-embedded/sgpp-lite-arm-linux-bin/metadata.xml5
-rw-r--r--dev-embedded/sgpp-lite-arm-linux-bin/sgpp-lite-arm-linux-bin-2010.09.50.ebuild48
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-embedded/sgpp-lite-arm-linux-bin/Manifest b/dev-embedded/sgpp-lite-arm-linux-bin/Manifest
new file mode 100644
index 000000000000..48bbc0959f89
--- /dev/null
+++ b/dev-embedded/sgpp-lite-arm-linux-bin/Manifest
@@ -0,0 +1 @@
+DIST arm-2010.09-50-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2 88213477 SHA256 60a3c3fd62424ee41cc54e9eaf96eb4ee4360756c4f26e63224bdd2575ec73f6 SHA512 1c85b321c79e424d4f2687ec96dbde6b3f3e62cc15ff9f4d81f01391e39821356542bde244c623a40c449ea1198fefacf844574d6df9342f08fc1d4bd1ff834c WHIRLPOOL 0b50aab67b80565272912b34eca8294da8665fa8071c21458d755012185520a8aee1aa6a22f261078ae4a1de6a7084c418d92fee16185437f2d08d42807fbf63
diff --git a/dev-embedded/sgpp-lite-arm-linux-bin/metadata.xml b/dev-embedded/sgpp-lite-arm-linux-bin/metadata.xml
new file mode 100644
index 000000000000..92114080841c
--- /dev/null
+++ b/dev-embedded/sgpp-lite-arm-linux-bin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+</pkgmetadata>
diff --git a/dev-embedded/sgpp-lite-arm-linux-bin/sgpp-lite-arm-linux-bin-2010.09.50.ebuild b/dev-embedded/sgpp-lite-arm-linux-bin/sgpp-lite-arm-linux-bin-2010.09.50.ebuild
new file mode 100644
index 000000000000..4e98fe06f8df
--- /dev/null
+++ b/dev-embedded/sgpp-lite-arm-linux-bin/sgpp-lite-arm-linux-bin-2010.09.50.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+CPU="arm"
+TARGET="arm-none-linux-gnueabi"
+HOST="i686-pc-linux-gnu"
+MY_P="${CPU}-${PV%.*}-${PV##*.}-${TARGET}-${HOST}"
+
+DESCRIPTION="regular, validated releases of the GNU Toolchain for ${CPU} processors by CodeSourcery"
+HOMEPAGE="http://www.codesourcery.com/sgpp/lite/${CPU}"
+SRC_URI="http://www.codesourcery.com/public/gnu_toolchain/${TARGET}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+RESTRICT="strip" # package is already stripped, and contains target bins
+QA_EXECSTACK="opt/${P}/*"
+
+RDEPEND="sys-libs/glibc"
+DEPEND=""
+
+S=${WORKDIR}/${CPU}-${PV%.*}
+
+src_install() {
+ local d="/opt/${P}"
+ dodir ${d}
+ cp -pPR * "${D}"/${d}/ || die
+
+ pushd "${D}"/${d}/share/doc/${CPU}-${TARGET} >/dev/null
+ if use doc ; then
+ dohtml -r html/* || die
+ dodoc pdf/* || die
+ fi
+ rm -rf html pdf
+ rm LICENSE.txt man/man7/{fsf-funding,gpl,gfdl}.7 || die
+ mv man info ../..
+ popd >/dev/null
+ find "${D}" -depth -type d -empty -delete
+
+ cat <<-EOF > "${T}"/15${P}
+ PATH=${d}/bin
+ MANPATH=${d}/share/man
+ INFOPATH=${d}/share/info
+ EOF
+ doenvd "${T}"/15${P} || die
+}