summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-15 14:30:08 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-15 14:30:08 -0400
commit7455a74803721727671c69e21c3287d9efd8bd1c (patch)
tree5549d63f7567a3d441fd6a5762d876c725621671 /dev-embedded
parentdev-ruby/rspec: arm stable, bug #666742 (diff)
downloadgentoo-7455a74803721727671c69e21c3287d9efd8bd1c.tar.gz
gentoo-7455a74803721727671c69e21c3287d9efd8bd1c.tar.bz2
gentoo-7455a74803721727671c69e21c3287d9efd8bd1c.zip
dev-embedded/arduino-builder: skip broken tests
Some tests require network and fail within a network sandbox. Closes: https://bugs.gentoo.org/668528 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/arduino-builder/arduino-builder-1.3.25.ebuild3
-rw-r--r--dev-embedded/arduino-builder/arduino-builder-1.4.1.ebuild5
-rw-r--r--dev-embedded/arduino-builder/files/arduino-builder-1.3.25-skip-tests.patch109
-rw-r--r--dev-embedded/arduino-builder/files/arduino-builder-1.4.1-skip-tests.patch129
4 files changed, 244 insertions, 2 deletions
diff --git a/dev-embedded/arduino-builder/arduino-builder-1.3.25.ebuild b/dev-embedded/arduino-builder/arduino-builder-1.3.25.ebuild
index 0930e5240c01..4ffdc5d8fdc1 100644
--- a/dev-embedded/arduino-builder/arduino-builder-1.3.25.ebuild
+++ b/dev-embedded/arduino-builder/arduino-builder-1.3.25.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -48,6 +48,7 @@ src_prepare() {
# path paths so that they point to system ctags and avrdude
eapply "${FILESDIR}/arduino-builder-1.3.25-platform-paths.patch"
+ eapply "${FILESDIR}/arduino-builder-1.3.25-skip-tests.patch"
default
}
diff --git a/dev-embedded/arduino-builder/arduino-builder-1.4.1.ebuild b/dev-embedded/arduino-builder/arduino-builder-1.4.1.ebuild
index c9c446bec655..078347f52348 100644
--- a/dev-embedded/arduino-builder/arduino-builder-1.4.1.ebuild
+++ b/dev-embedded/arduino-builder/arduino-builder-1.4.1.ebuild
@@ -36,7 +36,10 @@ DEPEND=">=dev-lang/go-1.9.2
dev-go/go-net
dev-go/go-text"
-PATCHES=("${FILESDIR}/arduino-builder-1.4.1-platform-paths.patch")
+PATCHES=(
+ "${FILESDIR}/arduino-builder-1.4.1-platform-paths.patch"
+ "${FILESDIR}/arduino-builder-1.4.1-skip-tests.patch"
+)
src_unpack() {
golang-vcs-snapshot_src_unpack
diff --git a/dev-embedded/arduino-builder/files/arduino-builder-1.3.25-skip-tests.patch b/dev-embedded/arduino-builder/files/arduino-builder-1.3.25-skip-tests.patch
new file mode 100644
index 000000000000..4ed170061c16
--- /dev/null
+++ b/dev-embedded/arduino-builder/files/arduino-builder-1.3.25-skip-tests.patch
@@ -0,0 +1,109 @@
+Skip tests that can't run on Gentoo because of the network sandbox
+diff --git a/src/arduino.cc/builder/test/hardware_loader_test.go b/src/arduino.cc/builder/test/hardware_loader_test.go
+index c9ea1d5..e7c68d2 100644
+--- a/src/arduino.cc/arduino-builder/src/arduino.cc/builder/test/hardware_loader_test.go
++++ b/src/arduino.cc/arduino-builder/src/arduino.cc/builder/test/hardware_loader_test.go
+@@ -41,6 +41,7 @@ import (
+ )
+
+ func TestLoadHardware(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{"downloaded_hardware", filepath.Join("..", "hardware"), "hardware"},
+ }
+@@ -85,6 +86,7 @@ func TestLoadHardware(t *testing.T) {
+ }
+
+ func TestLoadHardwareMixingUserHardwareFolder(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{"downloaded_hardware", filepath.Join("..", "hardware"), "hardware", "user_hardware"},
+ }
+@@ -155,6 +157,7 @@ func TestLoadHardwareMixingUserHardwareFolder(t *testing.T) {
+ }
+
+ func TestLoadHardwareWithBoardManagerFolderStructure(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{"downloaded_board_manager_stuff"},
+ }
+@@ -203,6 +206,7 @@ func TestLoadHardwareWithBoardManagerFolderStructure(t *testing.T) {
+ }
+
+ func TestLoadLotsOfHardware(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{"downloaded_board_manager_stuff", "downloaded_hardware", filepath.Join("..", "hardware"), "hardware", "user_hardware"},
+ }
+diff --git a/src/arduino.cc/builder/test/helper_tools_downloader.go b/src/arduino.cc/builder/test/helper_tools_downloader.go
+index 3642510..e6391b6 100644
+--- a/src/arduino.cc/arduino-builder/src/arduino.cc/builder/test/helper_tools_downloader.go
++++ b/src/arduino.cc/arduino-builder/src/arduino.cc/builder/test/helper_tools_downloader.go
+@@ -83,6 +83,7 @@ type Core struct {
+ }
+
+ func DownloadCoresAndToolsAndLibraries(t *testing.T) {
++ t.Skip("Gentoo skips tests requiring network");
+ cores := []Core{
+ Core{Maintainer: "arduino", Arch: "avr", Version: "1.6.10"},
+ Core{Maintainer: "arduino", Arch: "sam", Version: "1.6.7"},
+@@ -165,6 +166,7 @@ func patchFiles(t *testing.T) {
+ }
+
+ func download(t *testing.T, cores, boardsManagerCores, boardsManagerRedBearCores []Core, tools, toolsMultipleVersions, boardsManagerTools, boardsManagerRFduinoTools []Tool, libraries []Library) {
++ t.Skip("Gentoo skips tests requiring network");
+ allCoresDownloaded, err := allCoresAlreadyDownloadedAndUnpacked(HARDWARE_FOLDER, cores)
+ NoError(t, err)
+ if allCoresDownloaded &&
+diff --git a/src/arduino.cc/builder/test/target_board_resolver_test.go b/src/arduino.cc/builder/test/target_board_resolver_test.go
+index 274eb92..d6973e3 100644
+--- a/src/arduino.cc/arduino-builder/src/arduino.cc/builder/test/target_board_resolver_test.go
++++ b/src/arduino.cc/arduino-builder/src/arduino.cc/builder/test/target_board_resolver_test.go
+@@ -39,6 +39,7 @@ import (
+ )
+
+ func TestTargetBoardResolverUno(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware"},
+ FQBN: "arduino:avr:uno",
+@@ -64,6 +65,7 @@ func TestTargetBoardResolverUno(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverDue(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware"},
+ FQBN: "arduino:sam:arduino_due_x",
+@@ -89,6 +91,7 @@ func TestTargetBoardResolverDue(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverMega1280(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware"},
+ FQBN: "arduino:avr:mega:cpu=atmega1280",
+@@ -115,6 +118,7 @@ func TestTargetBoardResolverMega1280(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverMega2560(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware"},
+ FQBN: "arduino:avr:mega:cpu=atmega2560",
+@@ -141,6 +145,7 @@ func TestTargetBoardResolverMega2560(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverCustomYun(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware", "user_hardware"},
+ FQBN: "my_avr_platform:avr:custom_yun",
+@@ -167,6 +172,7 @@ func TestTargetBoardResolverCustomYun(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverCustomCore(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware", "user_hardware"},
+ FQBN: "watterott:avr:attiny841:core=spencekonde,info=info",
diff --git a/dev-embedded/arduino-builder/files/arduino-builder-1.4.1-skip-tests.patch b/dev-embedded/arduino-builder/files/arduino-builder-1.4.1-skip-tests.patch
new file mode 100644
index 000000000000..f66e829e4b01
--- /dev/null
+++ b/dev-embedded/arduino-builder/files/arduino-builder-1.4.1-skip-tests.patch
@@ -0,0 +1,129 @@
+Skip tests that can't run on Gentoo because of the network sandbox
+diff --git a/test/hardware_loader_test.go b/test/hardware_loader_test.go
+index 147396e..da6c8ef 100644
+--- a/src/github.com/arduino/arduino-builder/test/hardware_loader_test.go
++++ b/src/github.com/arduino/arduino-builder/test/hardware_loader_test.go
+@@ -41,6 +41,7 @@ import (
+ )
+
+ func TestLoadHardware(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{"downloaded_hardware", filepath.Join("..", "hardware"), "hardware"},
+ }
+@@ -85,6 +86,7 @@ func TestLoadHardware(t *testing.T) {
+ }
+
+ func TestLoadHardwareMixingUserHardwareFolder(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{"downloaded_hardware", filepath.Join("..", "hardware"), "hardware", "user_hardware"},
+ }
+@@ -155,6 +157,7 @@ func TestLoadHardwareMixingUserHardwareFolder(t *testing.T) {
+ }
+
+ func TestLoadHardwareWithBoardManagerFolderStructure(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{"downloaded_board_manager_stuff"},
+ }
+@@ -203,6 +206,7 @@ func TestLoadHardwareWithBoardManagerFolderStructure(t *testing.T) {
+ }
+
+ func TestLoadLotsOfHardware(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{"downloaded_board_manager_stuff", "downloaded_hardware", filepath.Join("..", "hardware"), "hardware", "user_hardware"},
+ }
+diff --git a/test/helper_tools_downloader.go b/test/helper_tools_downloader.go
+index 49aa847..ba77a57 100644
+--- a/src/github.com/arduino/arduino-builder/test/helper_tools_downloader.go
++++ b/src/github.com/arduino/arduino-builder/test/helper_tools_downloader.go
+@@ -83,6 +83,7 @@ type Core struct {
+ }
+
+ func DownloadCoresAndToolsAndLibraries(t *testing.T) {
++ t.Skip("Gentoo skips tests requiring network");
+ cores := []Core{
+ Core{Maintainer: "arduino", Arch: "avr", Version: "1.6.10"},
+ Core{Maintainer: "arduino", Arch: "sam", Version: "1.6.7"},
+@@ -177,6 +178,7 @@ func patchFiles(t *testing.T) {
+ }
+
+ func download(t *testing.T, cores, boardsManagerCores, boardsManagerRedBearCores []Core, tools, toolsMultipleVersions, boardsManagerTools, boardsManagerRFduinoTools []Tool, libraries []Library) {
++ t.Skip("Gentoo skips tests requiring network");
+ allCoresDownloaded, err := allCoresAlreadyDownloadedAndUnpacked(HARDWARE_FOLDER, cores)
+ NoError(t, err)
+ if allCoresDownloaded &&
+diff --git a/test/target_board_resolver_test.go b/test/target_board_resolver_test.go
+index 49e0abe..7a50fe1 100644
+--- a/src/github.com/arduino/arduino-builder/test/target_board_resolver_test.go
++++ b/src/github.com/arduino/arduino-builder/test/target_board_resolver_test.go
+@@ -39,6 +39,7 @@ import (
+ )
+
+ func TestTargetBoardResolverUno(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware"},
+ FQBN: "arduino:avr:uno",
+@@ -64,6 +65,7 @@ func TestTargetBoardResolverUno(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverDue(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware"},
+ FQBN: "arduino:sam:arduino_due_x",
+@@ -89,6 +91,7 @@ func TestTargetBoardResolverDue(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverMega1280(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware"},
+ FQBN: "arduino:avr:mega:cpu=atmega1280",
+@@ -115,6 +118,7 @@ func TestTargetBoardResolverMega1280(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverMega2560(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware"},
+ FQBN: "arduino:avr:mega:cpu=atmega2560",
+@@ -141,6 +145,7 @@ func TestTargetBoardResolverMega2560(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverCustomYun(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware", "user_hardware"},
+ FQBN: "my_avr_platform:avr:custom_yun",
+@@ -167,6 +172,7 @@ func TestTargetBoardResolverCustomYun(t *testing.T) {
+ }
+
+ func TestTargetBoardResolverCustomCore(t *testing.T) {
++ t.Skip("Can't run on Gentoo")
+ ctx := &types.Context{
+ HardwareFolders: []string{filepath.Join("..", "hardware"), "hardware", "downloaded_hardware", "user_hardware"},
+ FQBN: "watterott:avr:attiny841:core=spencekonde,info=info",
+diff --git a/test/wipeout_build_path_if_build_options_changed_test.go b/test/wipeout_build_path_if_build_options_changed_test.go
+index 51bfe80..8501fb6 100644
+--- a/src/github.com/arduino/arduino-builder/test/wipeout_build_path_if_build_options_changed_test.go
++++ b/src/github.com/arduino/arduino-builder/test/wipeout_build_path_if_build_options_changed_test.go
+@@ -42,6 +42,7 @@ import (
+ )
+
+ func TestWipeoutBuildPathIfBuildOptionsChanged(t *testing.T) {
++ t.Skip("Can't run in Gentoo")
+ ctx := &types.Context{}
+
+ buildPath := SetupBuildPath(t, ctx)
+@@ -73,6 +74,7 @@ func TestWipeoutBuildPathIfBuildOptionsChanged(t *testing.T) {
+ }
+
+ func TestWipeoutBuildPathIfBuildOptionsChangedNoPreviousBuildOptions(t *testing.T) {
++ t.Skip("Can't run in Gentoo")
+ ctx := &types.Context{}
+
+ buildPath := SetupBuildPath(t, ctx)