summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2018-10-24 22:12:59 +0100
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2018-10-24 22:53:54 +0100
commiteede150bda8fa32a248ddd74056aafda3d7ca252 (patch)
tree3d8a9b10dd0811243b5056822114dbd2865a25cc /dev-erlang/p1_oauth2
parentdev-erlang/proper: Bump version (diff)
downloadgentoo-eede150bda8fa32a248ddd74056aafda3d7ca252.tar.gz
gentoo-eede150bda8fa32a248ddd74056aafda3d7ca252.tar.bz2
gentoo-eede150bda8fa32a248ddd74056aafda3d7ca252.zip
dev-erlang/p1_oauth2: Bump version
Thanks to Rion <rion4ik@gmail.com>. Bug: https://bugs.gentoo.org/626260 Signed-off-by: Amadeusz Piotr Żołnowski <aidecoe@gentoo.org>
Diffstat (limited to 'dev-erlang/p1_oauth2')
-rw-r--r--dev-erlang/p1_oauth2/Manifest1
-rw-r--r--dev-erlang/p1_oauth2/p1_oauth2-0.6.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-erlang/p1_oauth2/Manifest b/dev-erlang/p1_oauth2/Manifest
index 6b5c307bfcee..c6ff35c152ff 100644
--- a/dev-erlang/p1_oauth2/Manifest
+++ b/dev-erlang/p1_oauth2/Manifest
@@ -1 +1,2 @@
DIST p1_oauth2-0.6.1.tar.gz 212804 BLAKE2B 571341aaa4d3a4bac6ac2f8f46d2e4b9caf5e00622a392635d79ff11b520a3cab71d360220c99a46035ce851974d975d69a71ac9b1be626c9b126941fc4a73cf SHA512 2509d48775579a26178fb5a082e628a8487c986b1b4d4abe974b653a1e0b7605bed934d59f6d62927582bdb95a53ba454816d326d99a77c5360928c4973ade4a
+DIST p1_oauth2-0.6.3.tar.gz 213860 BLAKE2B a610f7911ce46c30760dd8da42531ff1f4e4953f3158a42f360cec9090ca9901647bdedff5eacd7416e34bb64987cedcbb675c1c39de3a4172e337ec50c07495 SHA512 634606530f90810fb998baf26d14afc092699144506c9be771e74d5c965698d81b93bdc35ce53ff94d0b3ad1c4557a16660cfe74bc75586fbab2baa45b1d9c46
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.3.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.3.ebuild
new file mode 100644
index 000000000000..e5eb8b1ecc8f
--- /dev/null
+++ b/dev-erlang/p1_oauth2/p1_oauth2-0.6.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="Erlang OAuth 2.0 implementation"
+HOMEPAGE="https://github.com/processone/p1_oauth2"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.7
+ >=dev-erlang/proper-1.1_p20150814
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ rebar_src_prepare
+ rebar_remove_deps rebar.test.config
+ sed -e '/, warnings_as_errors/d' -i rebar.test.config || die
+}
+
+src_test() {
+ erebar -C rebar.test.config compile eunit
+}