summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-31 01:11:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-31 01:11:49 +0100
commit7dac17e60ff82f818465642833e69e101a9e8b27 (patch)
tree3b2f2c3d1e9296720f622ea91f92dff2711dde71 /dev-games/cegui
parentnet-analyzer/linkchecker: Sort RDEPENDs (diff)
downloadgentoo-7dac17e60ff82f818465642833e69e101a9e8b27.tar.gz
gentoo-7dac17e60ff82f818465642833e69e101a9e8b27.tar.bz2
gentoo-7dac17e60ff82f818465642833e69e101a9e8b27.zip
dev-games/cegui: Fix build with ICU 59
Thanks-to: Lars Wendler (Polynomial-C) <polynomial-c@gentoo.org> Closes: https://bugs.gentoo.org/618968 Package-Manager: Portage-2.3.21, Repoman-2.3.6
Diffstat (limited to 'dev-games/cegui')
-rw-r--r--dev-games/cegui/cegui-0.8.7.ebuild4
-rw-r--r--dev-games/cegui/files/cegui-0.8.7-icu-59.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-games/cegui/cegui-0.8.7.ebuild b/dev-games/cegui/cegui-0.8.7.ebuild
index 95a092f74924..179c88599c41 100644
--- a/dev-games/cegui/cegui-0.8.7.ebuild
+++ b/dev-games/cegui/cegui-0.8.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -56,6 +56,8 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
opengl? ( media-libs/glm )"
+PATCHES=( "${FILESDIR}"/${P}-icu-59.patch )
+
src_configure() {
# http://www.cegui.org.uk/mantis/view.php?id=991
append-ldflags $(no-as-needed)
diff --git a/dev-games/cegui/files/cegui-0.8.7-icu-59.patch b/dev-games/cegui/files/cegui-0.8.7-icu-59.patch
new file mode 100644
index 000000000000..e64dfc97ab59
--- /dev/null
+++ b/dev-games/cegui/files/cegui-0.8.7-icu-59.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -72,7 +72,7 @@
+
+ if ((CMAKE_CXX_COMPILER_ID STREQUAL "GNU") OR (CMAKE_CXX_COMPILER_ID STREQUAL "Clang"))
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99")
+- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++03")
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14")
+ elseif (NOT CMAKE_VERSION VERSION_LESS "3.1")
+ set (CMAKE_C_STANDARD_REQUIRED TRUE)
+ set (CMAKE_C_STANDARD "99")