summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-17 13:55:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-17 14:02:23 +0200
commit4a0816c22572ce1dba812e27eacba27bb1fb9431 (patch)
tree4ac4dfa63315387c2369ea8a9e2449b1237aee5d /dev-games/openscenegraph-qt
parentdev-vcs/qgit: Fix build with Qt 5.11 (diff)
downloadgentoo-4a0816c22572ce1dba812e27eacba27bb1fb9431.tar.gz
gentoo-4a0816c22572ce1dba812e27eacba27bb1fb9431.tar.bz2
gentoo-4a0816c22572ce1dba812e27eacba27bb1fb9431.zip
dev-games/openscenegraph-qt: Fix build with Qt 5.11_beta3
Package-Manager: Portage-2.3.29, Repoman-2.3.9
Diffstat (limited to 'dev-games/openscenegraph-qt')
-rw-r--r--dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-qt-5.11b3.patch36
-rw-r--r--dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild1
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-qt-5.11b3.patch b/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-qt-5.11b3.patch
new file mode 100644
index 000000000000..9618fde498e9
--- /dev/null
+++ b/dev-games/openscenegraph-qt/files/openscenegraph-qt-3.5.5-qt-5.11b3.patch
@@ -0,0 +1,36 @@
+From 91ba61ff69dc02a412eebae6222793e803b13ec2 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 17 Apr 2018 13:47:27 +0200
+Subject: [PATCH] Fix build with Qt 5.11_beta3 (dropping qt5_use_modules)
+
+---
+ CMakeLists.txt | 1 +
+ src/osgQt/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index aaea748..4345ea2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -487,6 +487,7 @@ ENDIF()
+
+ #If we have found Qt5, let's try to top off by getting the webkit as well
+ IF ( Qt5Widgets_FOUND )
++ FIND_PACKAGE(Qt5OpenGL REQUIRED)
+ FIND_PACKAGE(Qt5WebKitWidgets QUIET)
+
+ IF(COMMAND cmake_policy)
+diff --git a/src/osgQt/CMakeLists.txt b/src/osgQt/CMakeLists.txt
+index 60f3250..e4523e0 100644
+--- a/src/osgQt/CMakeLists.txt
++++ b/src/osgQt/CMakeLists.txt
+@@ -85,5 +85,5 @@ ENDIF( QT4_FOUND )
+ SETUP_LIBRARY(${LIB_NAME})
+
+ IF ( Qt5Widgets_FOUND )
+- qt5_use_modules( ${LIB_NAME} Widgets OpenGL )
++ TARGET_LINK_LIBRARIES( ${LIB_NAME} Qt5::Widgets Qt5::OpenGL )
+ ENDIF ( Qt5Widgets_FOUND )
+--
+2.17.0
+
diff --git a/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild
index 4426e581e4e5..2685d3688f4b 100644
--- a/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild
+++ b/dev-games/openscenegraph-qt/openscenegraph-qt-3.5.5.ebuild
@@ -32,6 +32,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-3.5.5-cmake.patch
+ "${FILESDIR}"/${PN}-3.5.5-qt-5.11b3.patch
)
src_configure() {