summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-21 22:53:23 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-21 23:14:31 +0000
commit6e9055b49516243cf12d1ebe1c04edb4b5252330 (patch)
tree91f534d0401c7fd60d0c4f5aeaedd9ba3e9c9d0d /dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch
parentnet-analyzer/fail2ban: adopt package (diff)
downloadgentoo-6e9055b49516243cf12d1ebe1c04edb4b5252330.tar.gz
gentoo-6e9055b49516243cf12d1ebe1c04edb4b5252330.tar.bz2
gentoo-6e9055b49516243cf12d1ebe1c04edb4b5252330.zip
dev-games/openscenegraph: migrate to lua-single.eclass
The usual cmake FindPackage(Lua) version hack. Lua compatibility as per upstream build scripts. Nb. The unmigrated 3.6.5 ebuild does not set -DOSG_USE_LOCAL_LUA_SOURCE=OFF in src_configure so it is a) always built with Lua support, and b) linked against bundled Lua. Closes: https://bugs.gentoo.org/752573 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch')
-rw-r--r--dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch b/dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch
new file mode 100644
index 000000000000..1373b296da04
--- /dev/null
+++ b/dev-games/openscenegraph/files/openscenegraph-3.6.5-cmake_lua_version.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -771,10 +771,7 @@
+ FIND_PACKAGE(LIBLAS)
+
+ IF (NOT(OSG_USE_LOCAL_LUA_SOURCE))
+- FIND_PACKAGE(Lua52)
+- IF (NOT (LUA_LIBRARIES AND LUA_INCLUDE_DIR))
+- FIND_PACKAGE(Lua51)
+- ENDIF()
++ FIND_PACKAGE(Lua ${LUA_VERSION} EXACT)
+ ENDIF()
+
+ # V8 and Python plugins are tests for linking against these libraries but aren't functionality beyond this.