summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-05-02 08:07:18 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-05-02 19:52:44 -0400
commitf962363558ed5f82c7d2b758e01cf7ab67299108 (patch)
treefd1fd3b5b3111384f0df571f98871e6a6345d543 /dev-gap/gaplint/gaplint-1.2.1.ebuild
parentsys-block/tgt: drop 1.0.90 (diff)
downloadgentoo-f962363558ed5f82c7d2b758e01cf7ab67299108.tar.gz
gentoo-f962363558ed5f82c7d2b758e01cf7ab67299108.tar.bz2
gentoo-f962363558ed5f82c7d2b758e01cf7ab67299108.zip
dev-gap/gaplint: new package, add 1.2.1
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-gap/gaplint/gaplint-1.2.1.ebuild')
-rw-r--r--dev-gap/gaplint/gaplint-1.2.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-gap/gaplint/gaplint-1.2.1.ebuild b/dev-gap/gaplint/gaplint-1.2.1.ebuild
new file mode 100644
index 000000000000..725d661d1d12
--- /dev/null
+++ b/dev-gap/gaplint/gaplint-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Linter for GAP"
+HOMEPAGE="
+ https://github.com/james-d-mitchell/gaplint
+ https://pypi.org/project/gaplint
+"
+
+# Use the github tarball because it includes the tests.
+SRC_URI="https://github.com/james-d-mitchell/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest