summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2019-01-01 13:19:30 -0600
committerWilliam Hubbs <williamh@gentoo.org>2019-01-01 13:20:02 -0600
commit63fb1d24566ccef345a348f716bbb203b896bf71 (patch)
tree22315fdaddb3fbb72142796ac17a188ca60af4b6 /dev-go/go-md2man/go-md2man-1.0.8.ebuild
parentgames-mud/gnome-mud-9999: updates (https git, gconf gone, higher glib dep) (diff)
downloadgentoo-63fb1d24566ccef345a348f716bbb203b896bf71.tar.gz
gentoo-63fb1d24566ccef345a348f716bbb203b896bf71.tar.bz2
gentoo-63fb1d24566ccef345a348f716bbb203b896bf71.zip
dev-go/go-md2man: 1.0.8 bump
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-go/go-md2man/go-md2man-1.0.8.ebuild')
-rw-r--r--dev-go/go-md2man/go-md2man-1.0.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-go/go-md2man/go-md2man-1.0.8.ebuild b/dev-go/go-md2man/go-md2man-1.0.8.ebuild
new file mode 100644
index 000000000000..c3767538421b
--- /dev/null
+++ b/dev-go/go-md2man/go-md2man-1.0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/cpuguy83/go-md2man
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~arm64"
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A utility to convert markdown to man pages"
+HOMEPAGE="https://github.com/cpuguy83/go-md2man"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+src_install() {
+ "${S}"/go-md2man -in src/${EGO_PN}/go-md2man.1.md -out go-md2man.1
+ dobin go-md2man
+ doman go-md2man.1
+}