summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-02-08 15:24:58 +0000
committerMarek Szuba <marecki@gentoo.org>2019-02-08 15:36:16 +0000
commitbe5f5ae7bcbb23c22691451021cda16a6c2074f3 (patch)
tree64668aaa6153bc8187d5ce7408896e64d7751074 /dev-go
parentdev-go/ed25519: bump to 0_pre20170117 and EAPI 7 (diff)
downloadgentoo-be5f5ae7bcbb23c22691451021cda16a6c2074f3.tar.gz
gentoo-be5f5ae7bcbb23c22691451021cda16a6c2074f3.tar.bz2
gentoo-be5f5ae7bcbb23c22691451021cda16a6c2074f3.zip
dev-go/siphash: bump to 1.2.1 and EAPI 7
Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/siphash/Manifest1
-rw-r--r--dev-go/siphash/siphash-1.2.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/siphash/Manifest b/dev-go/siphash/Manifest
index c062986e6e93..5b0d6f3c253c 100644
--- a/dev-go/siphash/Manifest
+++ b/dev-go/siphash/Manifest
@@ -1,2 +1,3 @@
DIST siphash-1.0.0.tar.gz 4462 BLAKE2B 2939eee829189db0939e2a0ff15701e7bc20b34213a5ea7b0e268a19d8eeb4618b26c11c537fd2902ce7bf3d573845a899f002155274a5172b67472879768cc5 SHA512 e52dc9857974ab362f2d7b2f7389644fbc07e7bb5507a93f138b3f692c1065303846611bb51b3d9c637d851a4d20cc20af146719a553801a8f7e17ec900a736a
DIST siphash-1.1.0.tar.gz 10543 BLAKE2B 50f1125024d37c0692616271c60d48c10584fbf1ea52cd6a7d48fba127d0d34561898ef0c507d62570112419265daf98c893eafd93f0c4f19de04a4facabe469 SHA512 f8892d5638417c610a1e06a4f3417438a4cc87f9ed8b432540a1b2fca8fe2a2feed395538f8cfc2b9663b5870a0f91c645aaa68119db603fc05e769d5f3e102b
+DIST siphash-1.2.1.tar.gz 10729 BLAKE2B 445e7839565224045ecb920787b7b75441fce6b028c22af6cbc498820e53c174f81851aff4e390f6d318557b720b4f32332b82f9ce4b4ba3a8725d74866a635f SHA512 bb59a152322350ce4d88f3a8795fcb319621f0c5b2e535f251e7c159ea574b22678f0e29c6dc0fde08ff1be628cd7c76534e902e3f1d332009031cae01491e11
diff --git a/dev-go/siphash/siphash-1.2.1.ebuild b/dev-go/siphash/siphash-1.2.1.ebuild
new file mode 100644
index 000000000000..19d1c036774f
--- /dev/null
+++ b/dev-go/siphash/siphash-1.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit golang-build golang-vcs-snapshot
+
+EGO_SRC=github.com/dchest/siphash
+EGO_PN=${EGO_SRC}/...
+EGIT_COMMIT="v${PV}"
+SRC_URI="https://github.com/dchest/siphash/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Go implementation of SipHash-2.4"
+HOMEPAGE="https://github.com/dchest/siphash"
+
+KEYWORDS="~amd64 ~arm ~x86"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""