summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-23 15:05:39 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-23 15:05:52 +0100
commit50c1a9fafc114f662de85209ad766b2c1d7789ec (patch)
treebd842f6598c7c27781e64b37392d2ab54dd74ecd /dev-haskell/binary
parentwww-client/chromium: remove old (diff)
downloadgentoo-50c1a9fafc114f662de85209ad766b2c1d7789ec.tar.gz
gentoo-50c1a9fafc114f662de85209ad766b2c1d7789ec.tar.bz2
gentoo-50c1a9fafc114f662de85209ad766b2c1d7789ec.zip
dev-haskell/binary: drop USE=test, bug #666810
Test suite is not compatible with modern QuickCheck instances: ``` tests/Arbitrary.hs:17:10: error: Duplicate instance declarations: instance (Arbitrary a, Arbitrary b, Arbitrary c, Arbitrary d, Arbitrary e, Arbitrary f) => Arbitrary (a, b, c, d, e, f) -- Defined at tests/Arbitrary.hs:17:10 -- Defined in ‘Test.QuickCheck.Arbitrary’ ``` Binary is not really an upgradeable package. Let's drop test suite completely. Reported-by: Pacho Ramos Closes: https://bugs.gentoo.org/666810 Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-haskell/binary')
-rw-r--r--dev-haskell/binary/binary-0.7.6.1.ebuild9
1 files changed, 2 insertions, 7 deletions
diff --git a/dev-haskell/binary/binary-0.7.6.1.ebuild b/dev-haskell/binary/binary-0.7.6.1.ebuild
index c35913aef133..124d0ca1b734 100644
--- a/dev-haskell/binary/binary-0.7.6.1.ebuild
+++ b/dev-haskell/binary/binary-0.7.6.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
# ebuild generated by hackport 0.4.6.9999
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # Avoid test-suite circular depend
inherit haskell-cabal
DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
@@ -23,11 +23,6 @@ RDEPEND=">=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
- test? ( dev-haskell/hunit
- >=dev-haskell/quickcheck-2.8
- >=dev-haskell/random-1.0.1.0
- dev-haskell/test-framework
- >=dev-haskell/test-framework-quickcheck2-0.3 )
"
CABAL_CORE_LIB_GHC_PV="PM:7.10.3_rc1 PM:7.10.3"