summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-04 07:33:55 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-04 07:33:55 +0100
commitb511a07a613be69d3865a08a7e8c418180b0f4b1 (patch)
tree0fd4609552b22a302dbe5a0cf5be6afedc92e50b /dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild
parentdev-haskell/aws: remove old (diff)
downloadgentoo-b511a07a613be69d3865a08a7e8c418180b0f4b1.tar.gz
gentoo-b511a07a613be69d3865a08a7e8c418180b0f4b1.tar.bz2
gentoo-b511a07a613be69d3865a08a7e8c418180b0f4b1.zip
dev-haskell/chasingbottoms: bump up to 1.3.1.9
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild')
-rw-r--r--dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild b/dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild
new file mode 100644
index 000000000000..34dd21581270
--- /dev/null
+++ b/dev-haskell/chasingbottoms/chasingbottoms-1.3.1.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: -build-tests
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="ChasingBottoms"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="For testing partial and infinite values"
+HOMEPAGE="http://hackage.haskell.org/package/ChasingBottoms"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/quickcheck-2.10:2=[profile?] <dev-haskell/quickcheck-2.15:2=[profile?]
+ >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/syb-0.1.0.2:=[profile?] <dev-haskell/syb-0.8:=[profile?]
+ >=dev-lang/ghc-7.6.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-build-tests
+}