summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/glob
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/glob')
-rw-r--r--dev-haskell/glob/Manifest3
-rw-r--r--dev-haskell/glob/glob-0.7.2.ebuild32
-rw-r--r--dev-haskell/glob/glob-0.7.3.ebuild32
-rw-r--r--dev-haskell/glob/glob-0.7.5.ebuild37
-rw-r--r--dev-haskell/glob/metadata.xml8
5 files changed, 112 insertions, 0 deletions
diff --git a/dev-haskell/glob/Manifest b/dev-haskell/glob/Manifest
new file mode 100644
index 000000000000..3de506e6030c
--- /dev/null
+++ b/dev-haskell/glob/Manifest
@@ -0,0 +1,3 @@
+DIST Glob-0.7.2.tar.gz 23498 SHA256 b164b2c294717eb452ee59c21ee33fd170ada5f76130cde56c307599fe818ff4 SHA512 8e680d62e2112d556b105982188f4ecede696ce8e0dec8a5c76ac2628a65a89b2b4040f377346a2383b355aaf7acf41f81da955298ba17695573dcc54d192098 WHIRLPOOL e7bd0fab75fd2fd20af573f1ddf51d33d33ba3aa621010d3fcbf3bd1fec3f3cad0b893ba6639c4fbe956064c04c8bd4a0e471caa0760e4499300a2d5c624a080
+DIST Glob-0.7.3.tar.gz 23616 SHA256 eda7a206c6544b09ab1d1b57cf629b12da3e5caa1c2b911d04bb0dd056e7807a SHA512 b818562a4de31458bf882628762f5002c42bbc4c0dbaf69e105fbb10fe12597a337800a5648d212e01befabcf1ccb54021c80e00ce19c9b3bfac41ef3ea8a799 WHIRLPOOL f630f5a76dfb30174ce8203e4bc7a78bb9ed55c81d4b8116eedde0880567ba4d04f5e5fc40fcc0dd845ad22fe5f97c3e52becf402a9267be294d730beb6cc0c1
+DIST Glob-0.7.5.tar.gz 23443 SHA256 0063bbc680d90f522455c0dec1121837689da542f4d9c70924d98bfb1389be41 SHA512 7397a6003b73fba31b1515ada667f2ff536cb1cc76d552e43167135877397dfc693a563abde11ca2912e0c005a99a37b45e564becadbd47d2c4e4f40ca4245b1 WHIRLPOOL fa82969b6c0d8b5e7804f10b183dc007c703adf56422405efa77d8d30fbdd83e880c7a8e7bf5e43da2d692fb665870e02bc763e459dc78c5598603a303520ead
diff --git a/dev-haskell/glob/glob-0.7.2.ebuild b/dev-haskell/glob/glob-0.7.2.ebuild
new file mode 100644
index 000000000000..b12c0d4ce081
--- /dev/null
+++ b/dev-haskell/glob/glob-0.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Glob"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Globbing library"
+HOMEPAGE="http://iki.fi/matti.niemenmaa/glob/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/dlist-0.4:=[profile?]
+ <dev-haskell/dlist-0.6:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/glob/glob-0.7.3.ebuild b/dev-haskell/glob/glob-0.7.3.ebuild
new file mode 100644
index 000000000000..1bf852c7789e
--- /dev/null
+++ b/dev-haskell/glob/glob-0.7.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Glob"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Globbing library"
+HOMEPAGE="http://iki.fi/matti.niemenmaa/glob/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/dlist-0.4:=[profile?] <dev-haskell/dlist-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/glob/glob-0.7.5.ebuild b/dev-haskell/glob/glob-0.7.5.ebuild
new file mode 100644
index 000000000000..326212aa6798
--- /dev/null
+++ b/dev-haskell/glob/glob-0.7.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Glob"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Globbing library"
+HOMEPAGE="http://iki.fi/matti.niemenmaa/glob/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/dlist-0.4:=[profile?] <dev-haskell/dlist-0.8:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal_chdeps \
+ 'filepath >= 1.1 && < 1.4' 'filepath >= 1.1'
+}
diff --git a/dev-haskell/glob/metadata.xml b/dev-haskell/glob/metadata.xml
new file mode 100644
index 000000000000..5616e0183695
--- /dev/null
+++ b/dev-haskell/glob/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A library for globbing: matching patterns against file paths.
+ </longdescription>
+</pkgmetadata>