summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/gtk3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/gtk3')
-rw-r--r--dev-haskell/gtk3/Manifest1
-rw-r--r--dev-haskell/gtk3/gtk3-0.13.7.ebuild53
-rw-r--r--dev-haskell/gtk3/metadata.xml14
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-haskell/gtk3/Manifest b/dev-haskell/gtk3/Manifest
new file mode 100644
index 000000000000..9d18123910eb
--- /dev/null
+++ b/dev-haskell/gtk3/Manifest
@@ -0,0 +1 @@
+DIST gtk3-0.13.7.tar.gz 673031 SHA256 29bf3dcdb39d01dbbced766ab1d72add67e73e01181668bc3423a71359d94f96 SHA512 c350ae55a7044684e6f2d94592decfcd01d3e96900a468cd417bad52713502c89c328f96cd4ff29647169a76287b8dada9654d46c4dc884c0dab0590ad57762e WHIRLPOOL 2045939ea93c510582a29b8427a607bcf931d8bd7cdaef9a3751fe3fa925bacebfa1ff4980c941470acfecd6b76fb08e99c3934b6b0577ab475bbf26c9e98e40
diff --git a/dev-haskell/gtk3/gtk3-0.13.7.ebuild b/dev-haskell/gtk3/gtk3-0.13.7.ebuild
new file mode 100644
index 000000000000..46c40f14394c
--- /dev/null
+++ b/dev-haskell/gtk3/gtk3-0.13.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+#nocabaldep is for the fancy cabal-detection feature at build-time
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ graphical user interface library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +fmode-binary +gio"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+ >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
+ >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.13.0.3:0=
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # workaround for module order
+ cabal_chdeps \
+ 'other-modules:' 'exposed-modules:'
+ # fix build with gcc 5.1.0 and later https://github.com/gtk2hs/gtk2hs/issues/104
+ sed -e 's@gccProg, "--cppopts=-E"@gccProg, "--cppopts=-E", "--cppopts=-P"@' \
+ -i Gtk2HsSetup.hs || die
+}
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag examples build-demos) \
+ $(cabal_flag fmode-binary fmode-binary) \
+ $(cabal_flag gio have-gio) \
+ --flags=-have-quartz-gtk
+}
diff --git a/dev-haskell/gtk3/metadata.xml b/dev-haskell/gtk3/metadata.xml
new file mode 100644
index 000000000000..ee8b0291295b
--- /dev/null
+++ b/dev-haskell/gtk3/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This is the core library of the Gtk2Hs suite of libraries for Haskell
+ based on Gtk+. Gtk+ is an extensive and mature multi-platform toolkit
+ for creating graphical user interfaces.
+ </longdescription>
+ <use>
+ <flag name="gio">Depend on GIO package, thereby enabling certain features.</flag>
+ <flag name="fmode-binary">Set the default file translation mode for file I/O operations to _O_BINARY.</flag>
+ </use>
+</pkgmetadata>