summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-09-05 16:31:41 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-09-06 22:44:24 +0100
commitb9740937c8e3eacc8c6ba7c6a05bfe8dee2db81f (patch)
tree47de1a26eb11095f48f48ebdef8adac06994d2f5 /dev-haskell/hoauth2/hoauth2-1.11.0.ebuild
parentmedia-libs/libheif: Stabilize 1.7.0-r1 arm64, #711240 (diff)
downloadgentoo-b9740937c8e3eacc8c6ba7c6a05bfe8dee2db81f.tar.gz
gentoo-b9740937c8e3eacc8c6ba7c6a05bfe8dee2db81f.tar.bz2
gentoo-b9740937c8e3eacc8c6ba7c6a05bfe8dee2db81f.zip
dev-haskell/hoauth2: bump up to 1.11.0
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Jack Todaro <solpeth@posteo.org> Closes: https://github.com/gentoo/gentoo/pull/17422 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/hoauth2/hoauth2-1.11.0.ebuild')
-rw-r--r--dev-haskell/hoauth2/hoauth2-1.11.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/hoauth2/hoauth2-1.11.0.ebuild b/dev-haskell/hoauth2/hoauth2-1.11.0.ebuild
new file mode 100644
index 000000000000..62e78143887b
--- /dev/null
+++ b/dev-haskell/hoauth2/hoauth2-1.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4
+#hackport: flags: -test
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell OAuth2 authentication client"
+HOMEPAGE="https://github.com/freizl/hoauth2"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-1.3.0.0:=[profile?] <dev-haskell/aeson-1.5:=[profile?]
+ >=dev-haskell/exceptions-0.8.3:=[profile?] <dev-haskell/exceptions-0.11:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?] <dev-haskell/http-conduit-2.4:=[profile?]
+ >=dev-haskell/http-types-0.11:=[profile?] <dev-haskell/http-types-0.13:=[profile?]
+ >=dev-haskell/microlens-0.4.0:=[profile?] <dev-haskell/microlens-0.5:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.5:=[profile?]
+ >=dev-haskell/uri-bytestring-0.2.3.1:=[profile?] <dev-haskell/uri-bytestring-0.4:=[profile?]
+ >=dev-haskell/uri-bytestring-aeson-0.1:=[profile?] <dev-haskell/uri-bytestring-aeson-0.2:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-test
+}