summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/hslua
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/hslua')
-rw-r--r--dev-haskell/hslua/Manifest2
-rw-r--r--dev-haskell/hslua/hslua-0.3.13.ebuild34
-rw-r--r--dev-haskell/hslua/hslua-0.3.6.1.ebuild24
-rw-r--r--dev-haskell/hslua/metadata.xml19
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-haskell/hslua/Manifest b/dev-haskell/hslua/Manifest
new file mode 100644
index 000000000000..f847f4c7256e
--- /dev/null
+++ b/dev-haskell/hslua/Manifest
@@ -0,0 +1,2 @@
+DIST hslua-0.3.13.tar.gz 128230 SHA256 e95774d21ac4378e799af4b8dce9068bfedd3109bf13b717d9ecb5817f86430a SHA512 5a11243f9a1da3a50ae5f30e310b2e661ed40655886b3bc6a2ba01b49fc0fbbc1ea20e24d3c227a8454cbcfd98161ad47edb5c3c111d6df09764f79476a9782a WHIRLPOOL 7dd80c1b90ca45df841d75c9efca238478da70ee92f4b7669250d4eb4c15fd685e7a266bd71cae0a6bbdc150aee3f39f5fdf104d917c0e18a5374a6c8d6e306d
+DIST hslua-0.3.6.1.tar.gz 127569 SHA256 37905c58a1f31bb6870a09b4be577c71f3060f65319120bee8d3dc0a9c7dc030 SHA512 abe8a8513d74fbdf94cc9486996264c074c6b4df8e21702a03c887772624fe33f86f805275dab11a340d7f14a6f3dad71f06aaf0f7e20951df1ef9f2e670863b WHIRLPOOL 8749f94ed8381d8c2620d30cfe7e248566b24919842bf35385cd52c02500c5fd3a9a9b7aaef429451f1594be5a6ab9ec5c3caa9b726846ec930bfbbd9604b929
diff --git a/dev-haskell/hslua/hslua-0.3.13.ebuild b/dev-haskell/hslua/hslua-0.3.13.ebuild
new file mode 100644
index 000000000000..7210a7888043
--- /dev/null
+++ b/dev-haskell/hslua/hslua-0.3.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A Lua language interpreter embedding in Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/hslua"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="apicheck system-lua"
+
+RDEPEND=">=dev-haskell/mtl-2.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ system-lua? ( dev-lang/lua )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ system-lua? ( virtual/pkgconfig )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag apicheck apicheck) \
+ $(cabal_flag system-lua system-lua)
+}
diff --git a/dev-haskell/hslua/hslua-0.3.6.1.ebuild b/dev-haskell/hslua/hslua-0.3.6.1.ebuild
new file mode 100644
index 000000000000..aacba28bf265
--- /dev/null
+++ b/dev-haskell/hslua/hslua-0.3.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A Lua language interpreter embedding in Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/hslua"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-2.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/hslua/metadata.xml b/dev-haskell/hslua/metadata.xml
new file mode 100644
index 000000000000..4e5483a95f1f
--- /dev/null
+++ b/dev-haskell/hslua/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <use>
+ <flag name="system-lua">Use the system-wide lua instead of the bundled copy.</flag>
+ </use>
+ <longdescription>
+ The Scripting.Lua module is a wrapper of Lua language interpreter
+ as described in www.lua.org.
+
+ The package is standalone: full Lua interpreter version 5.1.4
+ is distributed in this package as well.
+ </longdescription>
+ <use>
+ <flag name="system-lua">Use the system-wide lua instead of the bundled copy.</flag>
+ <flag name="apicheck">Compile Lua with -DLUA_USE_APICHECK..</flag>
+ </use>
+</pkgmetadata>