summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-08 21:48:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-10 16:13:47 +0100
commitcdc0774a75c8eecd1d68d2b0b1687884b88b9331 (patch)
tree9b77a5773bcffa670927e93a4a1d38456520b488 /dev-haskell/http
parentapp-i18n/man-pages-pl: drop old EAPI (diff)
downloadgentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.gz
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.tar.bz2
gentoo-cdc0774a75c8eecd1d68d2b0b1687884b88b9331.zip
*/*: Inline mirror://hackage and update URIs
This change inlines mirror://hackage in all ebuilds, and updates URIs to the modern form (old URIs redirect to that). The change has been made using the following command: find -name '*.ebuild' -exec sed -r -i \ -e 's@mirror://hackage/@https://hackage.haskell.org/@g' \ -e 's@https://hackage.haskell.org/packages/archive/([^/]*)/([^/]*)/@https://hackage.haskell.org/package/\1-\2/@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{PV}@${P}@g' \ -e '/hackage\.haskell\.org/s@\$\{MY_PN}-\$\{PV}@${MY_P}@g' \ -e '/hackage\.haskell\.org/s@\$\{PN}-\$\{MY_PV}@${MY_P}@g' \ {} + Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-haskell/http')
-rw-r--r--dev-haskell/http/http-4000.2.17.ebuild4
-rw-r--r--dev-haskell/http/http-4000.2.20.ebuild4
-rw-r--r--dev-haskell/http/http-4000.2.22.ebuild4
-rw-r--r--dev-haskell/http/http-4000.2.8.ebuild2
-rw-r--r--dev-haskell/http/http-4000.3.5.ebuild2
5 files changed, 8 insertions, 8 deletions
diff --git a/dev-haskell/http/http-4000.2.17.ebuild b/dev-haskell/http/http-4000.2.17.ebuild
index 6aee555e9218..31fc5ad72528 100644
--- a/dev-haskell/http/http-4000.2.17.ebuild
+++ b/dev-haskell/http/http-4000.2.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,7 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="A library for client-side HTTP"
HOMEPAGE="https://github.com/haskell/HTTP"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/http/http-4000.2.20.ebuild b/dev-haskell/http/http-4000.2.20.ebuild
index 5f21525ea490..77209ab8cfff 100644
--- a/dev-haskell/http/http-4000.2.20.ebuild
+++ b/dev-haskell/http/http-4000.2.20.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,7 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="A library for client-side HTTP"
HOMEPAGE="https://github.com/haskell/HTTP"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/http/http-4000.2.22.ebuild b/dev-haskell/http/http-4000.2.22.ebuild
index 1c867514970b..1cf5433a3a9b 100644
--- a/dev-haskell/http/http-4000.2.22.ebuild
+++ b/dev-haskell/http/http-4000.2.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,7 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="A library for client-side HTTP"
HOMEPAGE="https://github.com/haskell/HTTP"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/http/http-4000.2.8.ebuild b/dev-haskell/http/http-4000.2.8.ebuild
index 6556a4cd732a..f2471650d18b 100644
--- a/dev-haskell/http/http-4000.2.8.ebuild
+++ b/dev-haskell/http/http-4000.2.8.ebuild
@@ -13,7 +13,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="A library for client-side HTTP"
HOMEPAGE="https://github.com/haskell/HTTP"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
diff --git a/dev-haskell/http/http-4000.3.5.ebuild b/dev-haskell/http/http-4000.3.5.ebuild
index b5c0d4c06819..7156a2d16991 100644
--- a/dev-haskell/http/http-4000.3.5.ebuild
+++ b/dev-haskell/http/http-4000.3.5.ebuild
@@ -14,7 +14,7 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="A library for client-side HTTP"
HOMEPAGE="https://github.com/haskell/HTTP"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"