summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/math-functions
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/math-functions')
-rw-r--r--dev-haskell/math-functions/Manifest2
-rw-r--r--dev-haskell/math-functions/math-functions-0.1.3.0.ebuild32
-rw-r--r--dev-haskell/math-functions/math-functions-0.1.5.2.ebuild34
-rw-r--r--dev-haskell/math-functions/metadata.xml13
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-haskell/math-functions/Manifest b/dev-haskell/math-functions/Manifest
new file mode 100644
index 000000000000..fd746c637608
--- /dev/null
+++ b/dev-haskell/math-functions/Manifest
@@ -0,0 +1,2 @@
+DIST math-functions-0.1.3.0.tar.gz 23729 SHA256 c5abf1f44ef52c30e5dab9675e8fb8605e6568ea356ed1fd9d4f57b81cca9d1b SHA512 7c51614087a92f493563fbcfc932239e41db96387356e73a4b428612964b0a83e873ab7eabec5f32ffe743e575331eed6862cedd724fa381a90a795fae371d36 WHIRLPOOL 7512aa677c0d7fe6fad3be933f89d32558de694f061a3009ae4043d6103d7391d01ff1e2085954d7ac342438bea0c69f9a8140a0168b8573d89f9294de8ae6e5
+DIST math-functions-0.1.5.2.tar.gz 28490 SHA256 9ec9b809d33c3b4deebc07d8e776cb3f81866e99906ed84f9c4145fe8eb39f89 SHA512 7723400ef7eaf3996babc4cacc1b02b7ee46837b8c4105abf0aa69f896e97ce3fc9fae6e527a0513688d66810a05ce2f5bef527d04b54bedd82c16fe2bbe342b WHIRLPOOL 1ae5730d53e645aa40a82bcc501f65f578211c711b344f1253c7d8fd31a48e40b41f46bc1829eb90e41de680b6e1a11d7dff9ee70e3aba547433a42c3c53c65a
diff --git a/dev-haskell/math-functions/math-functions-0.1.3.0.ebuild b/dev-haskell/math-functions/math-functions-0.1.3.0.ebuild
new file mode 100644
index 000000000000..276dd2667e99
--- /dev/null
+++ b/dev-haskell/math-functions/math-functions-0.1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Special functions and Chebyshev polynomials"
+HOMEPAGE="https://github.com/bos/math-functions"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/erf-2:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/ieee754-0.7.3
+ >=dev-haskell/quickcheck-2.4
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ )
+ >=dev-haskell/cabal-1.8"
diff --git a/dev-haskell/math-functions/math-functions-0.1.5.2.ebuild b/dev-haskell/math-functions/math-functions-0.1.5.2.ebuild
new file mode 100644
index 000000000000..37cd7f1be1d0
--- /dev/null
+++ b/dev-haskell/math-functions/math-functions-0.1.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Special functions and Chebyshev polynomials"
+HOMEPAGE="https://github.com/bos/math-functions"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/erf-2:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ dev-haskell/vector-th-unbox:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/ieee754-0.7.3
+ >=dev-haskell/quickcheck-2.4
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"
diff --git a/dev-haskell/math-functions/metadata.xml b/dev-haskell/math-functions/metadata.xml
new file mode 100644
index 000000000000..b9dce45365c9
--- /dev/null
+++ b/dev-haskell/math-functions/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library provides implementations of special mathematical
+ functions and Chebyshev polynomials. These functions are often
+ useful in statistical and numerical computing.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">bos/math-functions</remote-id>
+ </upstream>
+</pkgmetadata>