summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/pcre-light
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/pcre-light')
-rw-r--r--dev-haskell/pcre-light/Manifest3
-rw-r--r--dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch39
-rw-r--r--dev-haskell/pcre-light/metadata.xml15
-rw-r--r--dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild28
-rw-r--r--dev-haskell/pcre-light/pcre-light-0.4.0.2.ebuild26
-rw-r--r--dev-haskell/pcre-light/pcre-light-0.4.0.3.ebuild26
6 files changed, 137 insertions, 0 deletions
diff --git a/dev-haskell/pcre-light/Manifest b/dev-haskell/pcre-light/Manifest
new file mode 100644
index 000000000000..5f2179b55b62
--- /dev/null
+++ b/dev-haskell/pcre-light/Manifest
@@ -0,0 +1,3 @@
+DIST pcre-light-0.4.0.2.tar.gz 15355 SHA256 ddda356c3dc0075d7fa2740a56845a68360baf896e3e9420ace68c399a21582d SHA512 03bd9cc98bb04452accfe124b674a19e24e1070d3839fc8b9c553ab14f10171315342c191e1b9432a9e8113a4dd5bd845425da597ebe1558bb0dc143edf96017 WHIRLPOOL 48ad5c0f8e8dc2f17ca8bd61bf5027b783f316441b1eb13e55f0a50583b037cf09ce12d8ece048bde85ef5a5b5c4af7d49848fef919ae078aa4252e92abf64d3
+DIST pcre-light-0.4.0.3.tar.gz 16574 SHA256 6e6309fe0f759fe685c8c58a14dd204f7691675b15adbd88208ee332b5702d50 SHA512 0fb9c5b0accec68adb52e7407e48b4ec1ae89f424539a03fe648fa58e501b5fe7b46299c75ac1df0157870e623beddcec018401eee1e5913202e754849146b2b WHIRLPOOL 5ca03f32eefe6b41473d5bc937a0f772cb7754ce5b0a97d5d86c105d0c92022cfd87f82817131f6c2074d1670f17ecb7853f8d5f8bc080051c9412e73cb65870
+DIST pcre-light-0.4.tar.gz 28943 SHA256 b37f6ffab07b56540ba4cc410f3ad3c4e0e6e226c610c33f4b7daf70559c31f6 SHA512 1cbb37743018e0199d3c23f5cda34a41514ecc375650f2a79935c16b12b4411e5ce1d7fc84b29fbb41458a2493998471cbefc54adbf848d59877c6be4d34b6aa WHIRLPOOL 61cea380f38fd3f67941a4e16a44a02828ca38d62fc896cc5fc34f6e1607192d11e24c66b3091ebfe7f3048f3ae5efd613422716a9d331e8e20204493cb84496
diff --git a/dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch b/dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch
new file mode 100644
index 000000000000..2b4181929f60
--- /dev/null
+++ b/dev-haskell/pcre-light/files/pcre-light-0.4-ghc-7.7.patch
@@ -0,0 +1,39 @@
+diff --git a/Text/Regex/PCRE/Light.hs b/Text/Regex/PCRE/Light.hs
+index 80c28a0..7fc9581 100644
+--- a/Text/Regex/PCRE/Light.hs
++++ b/Text/Regex/PCRE/Light.hs
+@@ -77,6 +77,7 @@ import qualified Data.ByteString as S
+ #if __GLASGOW_HASKELL__ >= 608
+ import qualified Data.ByteString.Internal as S
+ import qualified Data.ByteString.Unsafe as S
++import qualified System.IO.Unsafe as U
+ #else
+ import qualified Data.ByteString.Base as S
+ #endif
+@@ -193,7 +194,7 @@ compile s o = case compileM s o of
+ -- > Left "nothing to repeat"
+ --
+ compileM :: S.ByteString -> [PCREOption] -> Either String Regex
+-compileM str os = unsafePerformIO $
++compileM str os = U.unsafePerformIO $
+ S.useAsCString str $ \pattern -> do
+ alloca $ \errptr -> do
+ alloca $ \erroffset -> do
+@@ -263,7 +264,7 @@ compileM str os = unsafePerformIO $
+ -- is returned.
+ --
+ match :: Regex -> S.ByteString -> [PCREExecOption] -> Maybe [S.ByteString]
+-match (Regex pcre_fp _) subject os = unsafePerformIO $ do
++match (Regex pcre_fp _) subject os = U.unsafePerformIO $ do
+ withForeignPtr pcre_fp $ \pcre_ptr -> do
+ n_capt <- captureCount' pcre_ptr
+
+@@ -324,7 +325,7 @@ match (Regex pcre_fp _) subject os = unsafePerformIO $ do
+
+
+ captureCount :: Regex -> Int
+-captureCount (Regex pcre_fp _) = unsafePerformIO $ do
++captureCount (Regex pcre_fp _) = U.unsafePerformIO $ do
+ withForeignPtr pcre_fp $ \pcre_ptr -> do
+ captureCount' pcre_ptr
+
diff --git a/dev-haskell/pcre-light/metadata.xml b/dev-haskell/pcre-light/metadata.xml
new file mode 100644
index 000000000000..d1bdd43a1b80
--- /dev/null
+++ b/dev-haskell/pcre-light/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A small, efficient and portable regex library for Perl 5 compatible regular expressions
+
+ The PCRE library is a set of functions that implement regular
+ expression pattern matching using the same syntax and semantics as Perl 5.
+
+ Test coverage data for this library is available at:
+ &lt;http://code.haskell.org/~dons/tests/pcre-light/hpc_index.html&gt;
+
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild b/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild
new file mode 100644
index 000000000000..46b0bcf065a9
--- /dev/null
+++ b/dev-haskell/pcre-light/pcre-light-0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="A small, efficient and portable regex library for Perl 5 compatible regular expressions"
+HOMEPAGE="http://code.haskell.org/~dons/code/pcre-light"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+ dev-libs/libpcre
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-7.7.patch)
diff --git a/dev-haskell/pcre-light/pcre-light-0.4.0.2.ebuild b/dev-haskell/pcre-light/pcre-light-0.4.0.2.ebuild
new file mode 100644
index 000000000000..39e1401db907
--- /dev/null
+++ b/dev-haskell/pcre-light/pcre-light-0.4.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A small, efficient and portable regex library for Perl 5 compatible regular expressions"
+HOMEPAGE="https://github.com/Daniel-Diaz/pcre-light"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ dev-libs/libpcre
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.0
+"
diff --git a/dev-haskell/pcre-light/pcre-light-0.4.0.3.ebuild b/dev-haskell/pcre-light/pcre-light-0.4.0.3.ebuild
new file mode 100644
index 000000000000..7bfe6a097338
--- /dev/null
+++ b/dev-haskell/pcre-light/pcre-light-0.4.0.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A small, efficient and portable regex library for Perl 5 compatible regular expressions"
+HOMEPAGE="https://github.com/Daniel-Diaz/pcre-light"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ dev-libs/libpcre
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.0
+"