summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/punycode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/punycode')
-rw-r--r--dev-haskell/punycode/Manifest1
-rw-r--r--dev-haskell/punycode/metadata.xml11
-rw-r--r--dev-haskell/punycode/punycode-2.0.ebuild32
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-haskell/punycode/Manifest b/dev-haskell/punycode/Manifest
new file mode 100644
index 000000000000..1687488d5cf8
--- /dev/null
+++ b/dev-haskell/punycode/Manifest
@@ -0,0 +1 @@
+DIST punycode-2.0.tar.gz 6243 SHA256 59072915dbd5f94d5cc2e6ac84061b329ab84a9f22fd18a591ad5fdba37b52a4 SHA512 106ee29667582f0341b993b8fd888046e70aff02bf9a31fb883488ed0f1fe346ae6dacd60ceacf088c056b50cb99d633322f066be391585af9c37fd8e5e4ff44 WHIRLPOOL bdbf2b6bccee1f04df121b1a34b50b315791e77aad52b2d8b7e0727d73eaf36a9cd6e7d36b01af0d50973a0dfe71b17f0056c5dba3f92c56cba36ec28913c328
diff --git a/dev-haskell/punycode/metadata.xml b/dev-haskell/punycode/metadata.xml
new file mode 100644
index 000000000000..01e5554efcc8
--- /dev/null
+++ b/dev-haskell/punycode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Encode unicode strings to ascii forms according to RFC 3492. It is written in pure Haskell, as opposed to gnuidn's Data.Text.IDN.Punycode. Please note that Data.Encoding.BootString from the 'encoding' package also contains an implementation of the Punycode algorithm.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">litherum/punycode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/punycode/punycode-2.0.ebuild b/dev-haskell/punycode/punycode-2.0.ebuild
new file mode 100644
index 000000000000..5239a7ebac85
--- /dev/null
+++ b/dev-haskell/punycode/punycode-2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Encode unicode strings to ascii forms according to RFC 3492"
+HOMEPAGE="https://github.com/litherum/punycode"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RESTRICT=test # runs slow, finds error
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/encoding
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ )"