summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 16:46:05 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:16:00 +0000
commit0ddf5ce4335df4211515df3941014c1508d6934f (patch)
treed7b6b1eb38923df007a77d994de7139cda0fa155 /dev-haskell/vault/vault-0.3.1.5.ebuild
parentdev-haskell/uuid-types: add 1.0.5 (diff)
downloadgentoo-0ddf5ce4335df4211515df3941014c1508d6934f.tar.gz
gentoo-0ddf5ce4335df4211515df3941014c1508d6934f.tar.bz2
gentoo-0ddf5ce4335df4211515df3941014c1508d6934f.zip
dev-haskell/vault: add 0.3.1.5
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/vault/vault-0.3.1.5.ebuild')
-rw-r--r--dev-haskell/vault/vault-0.3.1.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/vault/vault-0.3.1.5.ebuild b/dev-haskell/vault/vault-0.3.1.5.ebuild
new file mode 100644
index 000000000000..a40aa93c8a5e
--- /dev/null
+++ b/dev-haskell/vault/vault-0.3.1.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: +useghc
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+CABAL_HACKAGE_REVISION="1"
+inherit haskell-cabal
+
+DESCRIPTION="a persistent store for values of arbitrary types"
+HOMEPAGE="https://github.com/HeinrichApfelmus/vault"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.5:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.3.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=useghc
+}