summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/vector
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/vector')
-rw-r--r--dev-haskell/vector/Manifest2
-rw-r--r--dev-haskell/vector/metadata.xml76
-rw-r--r--dev-haskell/vector/vector-0.10.0.1.ebuild39
-rw-r--r--dev-haskell/vector/vector-0.10.12.3.ebuild54
4 files changed, 171 insertions, 0 deletions
diff --git a/dev-haskell/vector/Manifest b/dev-haskell/vector/Manifest
new file mode 100644
index 000000000000..6a071cbdeb6c
--- /dev/null
+++ b/dev-haskell/vector/Manifest
@@ -0,0 +1,2 @@
+DIST vector-0.10.0.1.tar.gz 102426 SHA256 ece945058b01a77c5fff31e89bbea76ac619677041c41286a2da5e8b515508af SHA512 2595bee97295a62471de26748c0b598f40a9c5a75571e645c24a8f2bc4eef1d7a3e29d576e7ba9a9dca0fb071f0c178a5a3757e063219d1cf25d8c484e645754 WHIRLPOOL 24617c62582a4eb490e263dc69289e4b24ad18ab6dc6191b3fff52bbcb816cfda9d909c6a62b388daa1f7dd68d7bc9318d1c7618ff7a1a3db0b9cd631cc0ae4b
+DIST vector-0.10.12.3.tar.gz 103617 SHA256 0f765ce0238d89ffdb67656a364f7bf5012d68de9642da6bb2a425b61f88e89a SHA512 2b2c98f1fbaaf4f5e7243e18a08e373e85acb06dddf73a48d34b966bfd736efc72880babec9c47859bd8d6d6928a28ac9acd9134eb0ef61b2f88fa31bf18811b WHIRLPOOL b572031197f4992ad322c0d47843dbe20dc48372c0e3d1d53a6a0fe03a0c0c3d8f99ce7f13994bb5f5998bb8e9ee1fc225a67b15e63421484a8c371aebec5021
diff --git a/dev-haskell/vector/metadata.xml b/dev-haskell/vector/metadata.xml
new file mode 100644
index 000000000000..bcb6edfb532b
--- /dev/null
+++ b/dev-haskell/vector/metadata.xml
@@ -0,0 +1,76 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+
+ An efficient implementation of Int-indexed arrays (both mutable
+ and immutable), with a powerful loop optimisation framework .
+
+ It is structured as follows:
+
+ ["Data.Vector"] Boxed vectors of arbitrary types.
+
+ ["Data.Vector.Unboxed"] Unboxed vectors with an adaptive
+ representation based on data type families.
+
+ ["Data.Vector.Storable"] Unboxed vectors of 'Storable' types.
+
+ ["Data.Vector.Primitive"] Unboxed vectors of primitive types as
+ defined by the @primitive@ package. "Data.Vector.Unboxed" is more
+ flexible at no performance cost.
+
+ ["Data.Vector.Generic"] Generic interface to the vector types.
+
+ Each module has a @Safe@ version with is marked as @Trustworthy@
+ (see &lt;http://hackage.haskell.org/trac/ghc/wiki/SafeHaskell&gt;).
+
+ There is also a (draft) tutorial on common uses of vector.
+
+ * &lt;http://haskell.org/haskellwiki/Numeric_Haskell:_A_Vector_Tutorial&gt;
+
+ Please use the project trac to submit bug reports and feature
+ requests.
+
+ * &lt;http://trac.haskell.org/vector&gt;
+
+ Changes in version 0.9
+
+ * 'MonadPlus' instance for boxed vectors
+
+ * Export more @construct@ and @constructN@ from @Safe@ modules
+
+ * Require @primitive-0.4.0.1@
+
+ Changes in version 0.8
+
+ * New functions: @constructN@, @constructrN@
+
+ * Support for GHC 7.2 array copying primitives
+
+ * New fixity for @(!)@
+
+ * Safe Haskell support (contributed by David Terei)
+
+ * 'Functor', 'Monad', 'Applicative', 'Alternative', 'Foldable' and
+ 'Traversable' instances for boxed vectors
+ (/WARNING: they tend to be slow and are only provided for completeness/)
+
+ * 'Show' instances for immutable vectors follow containers conventions
+
+ * 'Read' instances for all immutable vector types
+
+ * Performance improvements
+
+ </longdescription>
+ <use>
+ <flag name="boundschecks">Enable bounds checking</flag>
+ <flag name="internalchecks">Enable internal consistency checks at the cost of a
+ significant performance penalty</flag>
+ <flag name="unsafechecks">Enable bounds checking in unsafe operations at the cost of a
+ significant performance penalty</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">haskell/vector</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-haskell/vector/vector-0.10.0.1.ebuild b/dev-haskell/vector/vector-0.10.0.1.ebuild
new file mode 100644
index 000000000000..790626a2e2db
--- /dev/null
+++ b/dev-haskell/vector/vector-0.10.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient Arrays"
+HOMEPAGE="http://code.haskell.org/vector"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-haskell/primitive-0.5.0.1:=[profile?] <dev-haskell/primitive-0.6:=[profile?]
+ >=dev-lang/ghc-6.12.3:= <dev-lang/ghc-7.8
+ ppc? ( >=dev-lang/ghc-7.6.1 )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3"
+
+src_prepare() {
+ local can_spec_const="yes"
+
+ ghc-supports-interpreter || can_spec_const="no"
+
+ # ghci-less GHC can't do ANN #482960
+ if [[ ${can_spec_const} == "no" ]]; then
+ einfo "Disabling 'ForceSpecConstr' due to bug #482960"
+ sed -e 's/{-# ANN type SPEC ForceSpecConstr #-}/{- # ANN type SPEC ForceSpecConstr #-}/' \
+ -i Data/Vector/Fusion/Stream/Monadic.hs || die
+ fi
+}
diff --git a/dev-haskell/vector/vector-0.10.12.3.ebuild b/dev-haskell/vector/vector-0.10.12.3.ebuild
new file mode 100644
index 000000000000..0b9834a8c85f
--- /dev/null
+++ b/dev-haskell/vector/vector-0.10.12.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Efficient Arrays"
+HOMEPAGE="https://github.com/haskell/vector"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="+boundschecks internalchecks unsafechecks"
+
+RDEPEND=">=dev-haskell/primitive-0.5.0.1:=[profile?] <dev-haskell/primitive-0.7:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.9
+ dev-haskell/random
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2
+ >=dev-haskell/transformers-0.2.0.0 )
+"
+
+src_prepare() {
+ local can_spec_const="yes"
+
+ cabal_chdeps \
+ "QuickCheck >= 2.7 && < 2.8" "QuickCheck >= 2.7 && < 2.9"
+
+ ghc-supports-interpreter || can_spec_const="no"
+
+ # ghci-less GHC can't do ANN #482960
+ if [[ ${can_spec_const} == "no" ]]; then
+ einfo "Disabling 'ForceSpecConstr' due to bug #482960"
+ sed -e 's/{-# ANN type SPEC ForceSpecConstr #-}/{- # ANN type SPEC ForceSpecConstr #-}/' \
+ -i Data/Vector/Fusion/Stream/Monadic.hs || die
+ fi
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag boundschecks boundschecks) \
+ $(cabal_flag internalchecks internalchecks) \
+ $(cabal_flag unsafechecks unsafechecks)
+}