summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-25 11:15:45 +1000
committerSam James <sam@gentoo.org>2022-07-25 04:02:53 +0100
commit0844be1f72d049d6886473a95ece5013b41ada56 (patch)
tree99c3c1b61e7f696364f9e260200f051fb0cc0bb7 /dev-haskell/x11-xft/x11-xft-0.3.4.ebuild
parentdev-haskell/x11: drop 1.9.2, 1.10-r1 (diff)
downloadgentoo-0844be1f72d049d6886473a95ece5013b41ada56.tar.gz
gentoo-0844be1f72d049d6886473a95ece5013b41ada56.tar.bz2
gentoo-0844be1f72d049d6886473a95ece5013b41ada56.zip
dev-haskell/x11-xft: add 0.3.4
Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/x11-xft/x11-xft-0.3.4.ebuild')
-rw-r--r--dev-haskell/x11-xft/x11-xft-0.3.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/x11-xft/x11-xft-0.3.4.ebuild b/dev-haskell/x11-xft/x11-xft-0.3.4.ebuild
new file mode 100644
index 000000000000..5967f57c6db3
--- /dev/null
+++ b/dev-haskell/x11-xft/x11-xft-0.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.2.1.9999
+#hackport: flags: -pedantic
+CABAL_PN="X11-xft"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Bindings to the Xft and some Xrender parts"
+HOMEPAGE="https://hackage.haskell.org/package/X11-xft"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-haskell/utf8-string-0.1:=[profile?]
+ >=dev-haskell/x11-1.2.1:=[xinerama,profile?]
+ >=dev-lang/ghc-8.4.3:=
+ x11-libs/libXft
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"
+BDEPEND="virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-pedantic
+}