summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:04:54 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:08:58 +0100
commit148bf291df46d3fb749d3626f3d5d841270de7df (patch)
tree8b7ddf9d20230e33376dfdb6396aa5b30201a0a8 /dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild
parentdev-haskell/pandoc-types: add 1.23.1 (diff)
downloadgentoo-148bf291df46d3fb749d3626f3d5d841270de7df.tar.gz
gentoo-148bf291df46d3fb749d3626f3d5d841270de7df.tar.bz2
gentoo-148bf291df46d3fb749d3626f3d5d841270de7df.zip
dev-haskell/xml-conduit: add 1.9.1.3
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild')
-rw-r--r--dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild b/dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild
new file mode 100644
index 000000000000..78a0351adb9c
--- /dev/null
+++ b/dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_FEATURES+=" rebuild-after-doc-workaround"
+inherit haskell-cabal
+
+DESCRIPTION="Pure-Haskell utilities for dealing with XML with the conduit package"
+HOMEPAGE="https://github.com/snoyberg/xml"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/conduit-extra-1.3:=[profile?] <dev-haskell/conduit-extra-1.4:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.4:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/xml-types-0.3.4:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0 <dev-haskell/cabal-4
+ >=dev-haskell/cabal-doctest-1.0.9 <dev-haskell/cabal-doctest-1.1
+ test? ( >=dev-haskell/doctest-0.8
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit )
+"
+
+GHC_BOOTSTRAP_PACKAGES=( cabal-doctest )