summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-11-26 07:37:35 +1100
committerSam James <sam@gentoo.org>2022-11-25 21:56:35 +0000
commit353ef3beaadf7a9482e03e3b018d2fa6bf1b4307 (patch)
tree872fa9e69e8ad598f238ad9394f91b0b4c2f30b5 /dev-haskell
parentdev-lang/ghc: sync from ::haskell (clang-16 workaround) (diff)
downloadgentoo-353ef3beaadf7a9482e03e3b018d2fa6bf1b4307.tar.gz
gentoo-353ef3beaadf7a9482e03e3b018d2fa6bf1b4307.tar.bz2
gentoo-353ef3beaadf7a9482e03e3b018d2fa6bf1b4307.zip
dev-haskell/unicode-collation: add 0.1.3.3
Closes: https://bugs.gentoo.org/882749 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/unicode-collation/Manifest1
-rw-r--r--dev-haskell/unicode-collation/unicode-collation-0.1.3.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/unicode-collation/Manifest b/dev-haskell/unicode-collation/Manifest
index 5b9b60120d20..174ae7a984c9 100644
--- a/dev-haskell/unicode-collation/Manifest
+++ b/dev-haskell/unicode-collation/Manifest
@@ -1 +1,2 @@
DIST unicode-collation-0.1.3.1.tar.gz 2057181 BLAKE2B dde95fbf322a2a9100e8c3a462744006e5e1c2934f0e99c410e311256bf22a0898a7a04960284ba5f801ebfbb3d7465eeedb8ba3a6545cd991b9ee4dd00270a5 SHA512 7c8de0e1c3053bdea7f4007fd7711d5d18fd2f19ddd78ffc3d51cab3ee34623faa51d45ea8408b3e079741bfed9bc453ecc89cc2e20f479280d3646f0f1ecc44
+DIST unicode-collation-0.1.3.3.tar.gz 2056081 BLAKE2B 1b5d58b852ff457b4c794d6e8c87c0539a5987240c2cdb8329fbb00b792be1105c194b55a10b5abd9c59eac7262194065d460a18e994edd2d7f71f535acb4f41 SHA512 bbb8fb3d52fa4906ddb92fb605f49b4c726cfcffd1f950c8a78bc495594a2e7d85fa78e2009da850f0218fce09a57f829ce0f3d6a6000b9b6484754f8c8260e8
diff --git a/dev-haskell/unicode-collation/unicode-collation-0.1.3.3.ebuild b/dev-haskell/unicode-collation/unicode-collation-0.1.3.3.ebuild
new file mode 100644
index 000000000000..e36006f5e702
--- /dev/null
+++ b/dev-haskell/unicode-collation/unicode-collation-0.1.3.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.3.0
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell implementation of the Unicode Collation Algorithm"
+HOMEPAGE="https://github.com/jgm/unicode-collation"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doctests executable"
+
+RDEPEND="dev-haskell/th-lift-instances:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ >=dev-haskell/unicode-transforms-0.3.7.1
+ doctests? ( >=dev-haskell/doctest-0.8 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag doctests doctests) \
+ $(cabal_flag executable executable)
+}