summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-21 08:54:30 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-21 08:57:27 +0000
commitd054873fb5793a081d5fef4dea47a23a3ccb1dba (patch)
tree0e1a0ab8dead9c5c040b6d8c0f3ebe6ba0af3d17 /dev-haskell
parentdev-haskell/basement: new package, a depend of foundation (diff)
downloadgentoo-d054873fb5793a081d5fef4dea47a23a3ccb1dba.tar.gz
gentoo-d054873fb5793a081d5fef4dea47a23a3ccb1dba.tar.bz2
gentoo-d054873fb5793a081d5fef4dea47a23a3ccb1dba.zip
dev-haskell/foundation: new package, a depend on memory
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/foundation/Manifest1
-rw-r--r--dev-haskell/foundation/foundation-0.0.25.ebuild40
-rw-r--r--dev-haskell/foundation/metadata.xml30
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-haskell/foundation/Manifest b/dev-haskell/foundation/Manifest
new file mode 100644
index 000000000000..a0dae253bcc2
--- /dev/null
+++ b/dev-haskell/foundation/Manifest
@@ -0,0 +1 @@
+DIST foundation-0.0.25.tar.gz 120472 BLAKE2B 2cff11363840b0b338b57d38438a13211e41a8e9bc6c359552dfb1854c9277c3228aac88b4a7930031fab75f78574cbe1cac6d5c87936f9b179e5c2277c00ff5 SHA512 7335795a1cdf2975d6e9471c5b469d99cc6d224d2da66838d830593a5abda73675920acb2dc823a6b92f2141dc2364c8fd5ad53d7e8aecd8df00e6998683be60
diff --git a/dev-haskell/foundation/foundation-0.0.25.ebuild b/dev-haskell/foundation/foundation-0.0.25.ebuild
new file mode 100644
index 000000000000..1f75b31ea271
--- /dev/null
+++ b/dev-haskell/foundation/foundation-0.0.25.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1.9999
+#hackport: flags: +doctest,-minimal-deps,-bench-all,-bounds-check,-linktest
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Alternative prelude with batteries and no dependencies"
+HOMEPAGE="https://github.com/haskell-foundation/foundation"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+RESTRICT="test" # fails to doctest
+
+RDEPEND="~dev-haskell/basement-0.0.11:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( dev-haskell/basement
+ >=dev-haskell/doctest-0.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-bench-all \
+ --flag=-bounds-check \
+ --flag=doctest \
+ $(cabal_flag experimental experimental) \
+ --flag=-linktest \
+ --flag=-minimal-deps
+}
diff --git a/dev-haskell/foundation/metadata.xml b/dev-haskell/foundation/metadata.xml
new file mode 100644
index 000000000000..f3416f8ccd59
--- /dev/null
+++ b/dev-haskell/foundation/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name='experimental'>enable building experimental features, known as highly unstable or without good support cross-platform</flag>
+ </use>
+ <longdescription>
+ A custom prelude with no dependencies apart from base.
+
+ This package has the following goals:
+
+ * provide a base like sets of modules that provide a consistent set of features and bugfixes across multiple versions of GHC (unlike base).
+
+ * provide a better and more efficient prelude than base&#39;s prelude.
+
+ * be self-sufficient: no external dependencies apart from base.
+
+ * provide better data-types: packed unicode string by default, arrays.
+
+ * Better numerical classes that better represent mathematical thing (No more all-in-one Num).
+
+ * Better I/O system with less Lazy IO
+
+ * Usual partial functions distinguished through type system
+ </longdescription>
+</pkgmetadata>