summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-10-26 13:10:05 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-11-29 10:16:20 +0100
commitb5348f34ca8e4f6eb022193c6a5983a1e54f0bd1 (patch)
tree4dcfa5ff168c85884d98c8730dd820aec96d71f0 /dev-java/bnd-annotation
parentdev-qt/qt-docs: Keyword 6.6.1_p202311210527 arm, #918719 (diff)
downloadgentoo-b5348f34ca8e4f6eb022193c6a5983a1e54f0bd1.tar.gz
gentoo-b5348f34ca8e4f6eb022193c6a5983a1e54f0bd1.tar.bz2
gentoo-b5348f34ca8e4f6eb022193c6a5983a1e54f0bd1.zip
dev-java: Rename dev-java/{qute-bnd-annotation -> bnd-annotation}
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/28334/commits/34db0d319eae29f839c90e63a9236d10ef956307 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/bnd-annotation')
-rw-r--r--dev-java/bnd-annotation/Manifest1
-rw-r--r--dev-java/bnd-annotation/bnd-annotation-6.3.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-java/bnd-annotation/Manifest b/dev-java/bnd-annotation/Manifest
new file mode 100644
index 000000000000..5b277a425cec
--- /dev/null
+++ b/dev-java/bnd-annotation/Manifest
@@ -0,0 +1 @@
+DIST biz.aQute.bnd.annotation-6.3.1-sources.jar 50600 BLAKE2B 6ace86a803c378be17b4ecfb658eb17e9c95f4f8797cdf22cbb9a5acb2a382fe0ee6791ad0280a2de9d9e85fbe2732487e693b2c93f08145b3633810f480f8b9 SHA512 751855a173e6d5f9d09f6d63775b97d971cebbfc019053988ec7fe144d0f49b4d09b9a2339d63bb43cea51d09d7d766554255f727cad8d73d9c196097e58d0fd
diff --git a/dev-java/bnd-annotation/bnd-annotation-6.3.1.ebuild b/dev-java/bnd-annotation/bnd-annotation-6.3.1.ebuild
new file mode 100644
index 000000000000..9522fc6820a9
--- /dev/null
+++ b/dev-java/bnd-annotation/bnd-annotation-6.3.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom biz.aQute.bnd.annotation-6.3.1.pom --download-uri https://repo1.maven.org/maven2/biz/aQute/bnd/biz.aQute.bnd.annotation/6.3.1/biz.aQute.bnd.annotation-6.3.1-sources.jar --slot 0 --keywords "~amd64 ~arm ~arm64 ~ppc64 ~x86" --ebuild aqute-bnd-annotation-6.3.1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="biz.aQute.bnd:biz.aQute.bnd.annotation:6.3.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="bnd Annotations Library"
+HOMEPAGE="https://bnd.bndtools.org/"
+SRC_URI="https://repo1.maven.org/maven2/biz/aQute/bnd/biz.aQute.bnd.annotation/${PV}/biz.aQute.bnd.annotation-${PV}-sources.jar"
+
+LICENSE="Apache-2.0 EPL-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ppc64 x86"
+
+# Common dependencies
+# POM: biz.aQute.bnd.annotation-${PV}.pom
+# org.osgi:org.osgi.resource:1.0.0 -> !!!artifactId-not-found!!!
+# org.osgi:org.osgi.service.serviceloader:1.0.0 -> !!!artifactId-not-found!!!
+
+CP_DEPEND="dev-java/osgi-annotation:0"
+
+# Compile dependencies
+# POM: biz.aQute.bnd.annotation-${PV}.pom
+# org.osgi:org.osgi.namespace.extender:1.0.1 -> !!!artifactId-not-found!!!
+# org.osgi:org.osgi.namespace.service:1.0.0 -> !!!artifactId-not-found!!!
+# org.osgi:osgi.annotation:8.1.0 -> >=dev-java/osgi-annotation-8.1.0:0
+
+DEPEND=">=virtual/jdk-1.8:*
+ dev-java/osgi-cmpn:8
+ dev-java/osgi-core:0
+ ${CP_DEPEND}"
+
+RDEPEND=">=virtual/jre-1.8:*
+ ${CP_DEPEND}"
+
+BDEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+JAVA_CLASSPATH_EXTRA="osgi-cmpn-8,osgi-core"
+JAVA_SRC_DIR="."