summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-11-24 21:56:58 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-11-24 21:56:58 +0000
commit97eb14e720de9e83a3b1040e101d5935c3e9802f (patch)
tree6700d5cf6d0b8ed77f4c3d2b5cbb64050711f40b /dev-java/commons-collections
parentsys-kernel/hardened-sources: version bump to 4.8.10 (diff)
downloadgentoo-97eb14e720de9e83a3b1040e101d5935c3e9802f.tar.gz
gentoo-97eb14e720de9e83a3b1040e101d5935c3e9802f.tar.bz2
gentoo-97eb14e720de9e83a3b1040e101d5935c3e9802f.zip
dev-java/commons-collections: Version bump to 4.1 into new SLOT 4
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/Manifest1
-rw-r--r--dev-java/commons-collections/commons-collections-4.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/commons-collections/Manifest b/dev-java/commons-collections/Manifest
index 0eb13b01eea7..8a4484d1436c 100644
--- a/dev-java/commons-collections/Manifest
+++ b/dev-java/commons-collections/Manifest
@@ -1 +1,2 @@
DIST commons-collections-3.2.1-src.tar.gz 609930 SHA256 9a4a800cb7ecdaf3b6f608cd608682b88b506f1b1c4b727d15471ae3329fc63d SHA512 8b9b5344528b3b8a53142abd944ff6b89cc149a3fa0c1eadf3f2172509499af5820ba86859e47fe7f15f994f680fa3c577c21891540b64f41f826babe81a0fc0 WHIRLPOOL ec31406560a1156e8e8780e3cc1d5be2b614b26e8dc3c04a80ee758d4d42c353c2eaf6f5f41057d3f9735063cb81143005bd63d7b552b73f1e2acc5fa644766d
+DIST commons-collections4-4.1-src.tar.gz 704671 SHA256 94839a0620a0fb1999aa94d490cd8d6919f79dc206be33b722f856ffde862ecf SHA512 c5666f41b68c9fdba3731730595616b16f98579c077cf047f421a46729b5a65476a8707125a2c0b0c6c024ca94df8c2633123bd99e705149fcb1afadcd3bf68b WHIRLPOOL 154bddba08d881303d888a6c195eceda7582677ac3cd0089d189b04b1d1673d9b7fa92e94c22298bc2ce3c12502ea731f51144ac22b7ff5ef9767c7bb2d816a0
diff --git a/dev-java/commons-collections/commons-collections-4.1.ebuild b/dev-java/commons-collections/commons-collections-4.1.ebuild
new file mode 100644
index 000000000000..7af72932698e
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+SLOT="4"
+MY_P="${PN}${SLOT}-${PV}"
+
+DESCRIPTION="Extends the JCF classes with new interfaces, implementations and utilities"
+HOMEPAGE="http://commons.apache.org/collections/"
+SRC_URI="mirror://apache/${PN/-//}/source/${MY_P}-src.tar.gz"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.7"
+
+DEPEND=">=virtual/jdk-1.7
+ test? (
+ dev-java/easymock:3.2
+ dev-java/junit:4
+ )"
+
+S="${WORKDIR}/${MY_P}-src"
+JAVA_SRC_DIR="src/main/java"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc RELEASE-NOTES.txt
+ docinto html
+ dodoc {DEVELOPERS-GUIDE,PROPOSAL}.html
+}
+
+src_test() {
+ local DIR=src/test/java
+ local CP="${DIR}:${DIR}/../resources:${PN}.jar:$(java-pkg_getjars easymock-3.2,junit-4)"
+ local TESTS=$(find ${DIR} -name "*Test.java" ! -name "Abstract*" ! -name "BulkTest.*")
+ TESTS="${TESTS//src\/test\/java\/}"
+ TESTS="${TESTS//.java}"
+ TESTS="${TESTS//\//.}"
+
+ ejavac -cp "${CP}" -d ${DIR} $(find ${DIR} -name "*.java")
+ ejunit4 -classpath "${CP}" ${TESTS}
+}