summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-jelly
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-jelly')
-rw-r--r--dev-java/commons-jelly/Manifest1
-rw-r--r--dev-java/commons-jelly/commons-jelly-1.0-r5.ebuild66
-rw-r--r--dev-java/commons-jelly/commons-jelly-1.0-r6.ebuild66
-rw-r--r--dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch59
-rw-r--r--dev-java/commons-jelly/metadata.xml5
5 files changed, 197 insertions, 0 deletions
diff --git a/dev-java/commons-jelly/Manifest b/dev-java/commons-jelly/Manifest
new file mode 100644
index 000000000000..c29e323f4ee6
--- /dev/null
+++ b/dev-java/commons-jelly/Manifest
@@ -0,0 +1 @@
+DIST commons-jelly-1.0-src.tar.gz 174769 SHA256 113d606361845d08dab69f187690bf5dcfb5e9ca8fab780135898eb6d0a8d7d1 SHA512 a72ae2dc8eea3fc19838f386dca38807a16326a3a93f483219212844f8ec033088b7721c78a4370f78a06cbee0c685144a2b16f171d54134822d06f653bcef35 WHIRLPOOL 3e92b517ce621cda2477354a1342c59d7cf7756edbc3c7746c262f5cdca5d015976979e35056dc2f588de37f4b882f21929e8c7a095251b1eba5857115659d2c
diff --git a/dev-java/commons-jelly/commons-jelly-1.0-r5.ebuild b/dev-java/commons-jelly/commons-jelly-1.0-r5.ebuild
new file mode 100644
index 000000000000..cefc4203e371
--- /dev/null
+++ b/dev-java/commons-jelly/commons-jelly-1.0-r5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P="${P}-src"
+DESCRIPTION="A Java and XML based scripting and processing engine"
+HOMEPAGE="http://commons.apache.org/jelly/"
+SRC_URI="mirror://apache/jakarta/commons/jelly/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/commons-beanutils:1.7
+ dev-java/commons-cli:1
+ dev-java/commons-collections:0
+ dev-java/commons-discovery:0
+ dev-java/commons-jexl:1.0
+ dev-java/commons-lang:0
+ dev-java/commons-logging:0
+ dev-java/dom4j:1
+ dev-java/jakarta-jstl:0
+ dev-java/jaxen:1.1
+ dev-java/junit:0
+ java-virtuals/servlet-api:2.5"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4
+ test? ( dev-java/ant-junit:0 )"
+
+S=${WORKDIR}/${MY_P}
+
+java_prepare() {
+ # disables dependency fetching, and remove tests as a dependency of jar
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_EXTRA_ARGS="-Dlibdir=."
+EANT_GENTOO_CLASSPATH="
+ commons-beanutils-1.7,commons-cli-1,commons-collections,commons-discovery
+ commons-jexl-1.0,commons-lang,commons-logging,dom4j-1,jakarta-jstl
+ jaxen-1.1,junit,servlet-api-2.5"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ dodoc NOTICE.txt README.txt RELEASE-NOTES.txt || die
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-jelly/commons-jelly-1.0-r6.ebuild b/dev-java/commons-jelly/commons-jelly-1.0-r6.ebuild
new file mode 100644
index 000000000000..0aca10135cfe
--- /dev/null
+++ b/dev-java/commons-jelly/commons-jelly-1.0-r6.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P="${P}-src"
+DESCRIPTION="A Java and XML based scripting and processing engine"
+HOMEPAGE="http://commons.apache.org/jelly/"
+SRC_URI="mirror://apache/jakarta/commons/jelly/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/commons-beanutils:1.7
+ dev-java/commons-cli:1
+ dev-java/commons-collections:0
+ dev-java/commons-discovery:0
+ dev-java/commons-jexl:1.0
+ dev-java/commons-lang:0
+ dev-java/commons-logging:0
+ dev-java/dom4j:1
+ dev-java/tomcat-jstl-spec:1.2.5
+ dev-java/jaxen:1.1
+ dev-java/junit:0
+ java-virtuals/servlet-api:2.5"
+RDEPEND="${COMMON_DEP}
+ >=virtual/jre-1.4"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.4
+ test? ( dev-java/ant-junit:0 )"
+
+S=${WORKDIR}/${MY_P}
+
+java_prepare() {
+ # disables dependency fetching, and remove tests as a dependency of jar
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+EANT_EXTRA_ARGS="-Dlibdir=."
+EANT_GENTOO_CLASSPATH="
+ commons-beanutils-1.7,commons-cli-1,commons-collections,commons-discovery
+ commons-jexl-1.0,commons-lang,commons-logging,dom4j-1,tomcat-jstl-spec-1.2.5
+ jaxen-1.1,junit,servlet-api-2.5"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ dodoc NOTICE.txt README.txt RELEASE-NOTES.txt || die
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch b/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
new file mode 100644
index 000000000000..8fafca81ea79
--- /dev/null
+++ b/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
@@ -0,0 +1,59 @@
+diff -ru commons-jelly-1.0-src/build.xml commons-jelly-1.0-src-patched/build.xml
+--- commons-jelly-1.0-src/build.xml 2005-06-16 10:39:44.000000000 -0400
++++ commons-jelly-1.0-src-patched/build.xml 2005-09-04 19:39:19.000000000 -0400
+@@ -37,6 +37,8 @@
+ <property name="proxy.password" value="">
+ </property>
+ <path id="build.classpath">
++ <fileset dir="${libdir}" includes="**/*.jar"/>
++ <!--
+ <pathelement location="${libdir}/servletapi/jars/servletapi-2.3.jar">
+ </pathelement>
+ <pathelement location="${libdir}/commons-cli/jars/commons-cli-1.0.jar">
+@@ -67,6 +69,7 @@
+ </pathelement>
+ <pathelement location="${libdir}/xerces/jars/xerces-2.2.1.jar">
+ </pathelement>
++ -->
+ </path>
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}">
+@@ -92,7 +95,7 @@
+ </and>
+ </condition>
+ </target>
+- <target name="compile" description="o Compile the code" depends="get-deps">
++ <target name="compile" description="o Compile the code" depends="">
+ <mkdir dir="${classesdir}">
+ </mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+@@ -120,10 +123,12 @@
+ <copy todir="${classesdir}/META-INF" file="${basedir}/LICENSE.txt">
+ </copy>
+ </target>
+- <target name="jar" description="o Create the jar" depends="compile,test">
++
++ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
+ </jar>
+ </target>
++
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}">
+ </delete>
+@@ -213,7 +218,7 @@
+ </fileset>
+ </copy>
+ </target>
+- <target name="javadoc" description="o Generate javadoc" depends="get-deps">
++ <target name="javadoc" description="o Generate javadoc" depends="">
+ <mkdir dir="${javadocdir}">
+ </mkdir>
+ <tstamp>
+@@ -432,4 +437,4 @@
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+-</project>
+\ No newline at end of file
++</project>
diff --git a/dev-java/commons-jelly/metadata.xml b/dev-java/commons-jelly/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-jelly/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>