summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-primitives
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-primitives')
-rw-r--r--dev-java/commons-primitives/Manifest1
-rw-r--r--dev-java/commons-primitives/commons-primitives-1.0-r2.ebuild29
-rw-r--r--dev-java/commons-primitives/metadata.xml14
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-java/commons-primitives/Manifest b/dev-java/commons-primitives/Manifest
new file mode 100644
index 000000000000..b74ef90f594f
--- /dev/null
+++ b/dev-java/commons-primitives/Manifest
@@ -0,0 +1 @@
+DIST commons-primitives-1.0-src.tar.gz 172369 SHA256 96927b484b8cac7e33612469099e7bbd7139cbc79666d5612a32c997fa671ac4 SHA512 239752a615f3a88049d6c85326a67462362869eda421ab76975c0906d811c970c871042769d851a4341c8a06b501d6b12fd1feba74d83007b2dd73370c5b3195 WHIRLPOOL 725644e8ef915e77313dabf6f397a54b857265bcf9d284b4444457d3872e6982cad3670101f1e1576158b1ceebf809348bb2dec2cecec87796a22595ace03129
diff --git a/dev-java/commons-primitives/commons-primitives-1.0-r2.ebuild b/dev-java/commons-primitives/commons-primitives-1.0-r2.ebuild
new file mode 100644
index 000000000000..76411ef52b5d
--- /dev/null
+++ b/dev-java/commons-primitives/commons-primitives-1.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Jakarta-Commons Primitives Component"
+HOMEPAGE="http://commons.apache.org/primitives/"
+SRC_URI="mirror://apache/jakarta/commons/primitives/source/${P}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+# Would need an old version of commons-collections and this would be the
+# only user. Trunk works against the latest version so hopefully they will
+# have a new release at some point.
+RESTRICT="test"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use doc && java-pkg_dojavadoc target/docs/api
+ use source && java-pkg_dosrc src/java/*
+}
diff --git a/dev-java/commons-primitives/metadata.xml b/dev-java/commons-primitives/metadata.xml
new file mode 100644
index 000000000000..72db416dc3ba
--- /dev/null
+++ b/dev-java/commons-primitives/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+ Apache Jakarta Commons Primitives provides a collection of types and
+ utilities optimized for working with Java primitives (boolean, byte,
+ char, double, float, int, long, short). Generally, the
+ Commons-Primitives classes are smaller, faster and easier to work with
+ than their purely Object based alternatives.
+</longdescription>
+</pkgmetadata>